summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2018-12-22 22:20:55 -0200
committerTércio Martins2018-12-22 22:20:55 -0200
commitf9147f36644388af51c3dd59375bdb51d4b39333 (patch)
treee825b9d4a66d27c5e81c9e772de7274d63ea4331
downloadaur-f9147f36644388af51c3dd59375bdb51d4b39333.tar.gz
Adding PKGBUILD to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD57
-rw-r--r--olive.desktop11
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c9141f0d2a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = olive
+ pkgdesc = Free non-linear video editor
+ pkgver = 20181130
+ pkgrel = 1
+ url = https://www.olivevideoeditor.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = libicns
+ depends = ffmpeg
+ depends = qt5-multimedia
+ source = 20181130.tar.gz::https://github.com/olive-editor/olive/archive/20181130.tar.gz
+ source = olive.desktop
+ sha512sums = 20b2e2e149194480df8e136a03af77e931858daefdfd4c68e95b48abf48cb09c6b3d7b60d6ebb401339ad2b0a7c3a46a93d1c75dffc70dbaf5a7340f576d4466
+ sha512sums = 5c6e6fb0309bfc6a45cde61051df285e8b092545dd56e08aa49c322dd5ce52f8b50f094e5056350222c78e38b1f07a179244beaf8053c923a9fe06d2bff21f3d
+
+pkgname = olive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffa94192e1de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=olive
+pkgver=20181130
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Free non-linear video editor"
+url="https://www.olivevideoeditor.org/"
+license=('GPL3')
+depends=('ffmpeg' 'qt5-multimedia')
+makedepends=('libicns')
+source=("${pkgver}.tar.gz::https://github.com/olive-editor/olive/archive/${pkgver}.tar.gz"
+ "olive.desktop"
+ )
+sha512sums=('20b2e2e149194480df8e136a03af77e931858daefdfd4c68e95b48abf48cb09c6b3d7b60d6ebb401339ad2b0a7c3a46a93d1c75dffc70dbaf5a7340f576d4466'
+ '5c6e6fb0309bfc6a45cde61051df285e8b092545dd56e08aa49c322dd5ce52f8b50f094e5056350222c78e38b1f07a179244beaf8053c923a9fe06d2bff21f3d'
+ )
+
+prepare() {
+ # Configure qmake project
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i '1s/^/target.path = \/usr\/bin\n/' $pkgname.pro
+ sed -i '1s/^/INSTALLS += target\n/' $pkgname.pro
+
+ # Extract icons from the ICNS file
+ cd "$srcdir/$pkgname-$pkgver/icons"
+ icns2png -x olive.icns
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake $pkgname.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -Dm644 "$srcdir/olive.desktop" \
+ "$pkgdir/usr/share/applications/olive.desktop"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_16x16x32.png" \
+ "$pkgdir/usr/share/icons/hicolor/16x16/apps/olive.png"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_32x32x32.png" \
+ "$pkgdir/usr/share/icons/hicolor/32x32/apps/olive.png"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_256x256x32.png" \
+ "$pkgdir/usr/share/icons/hicolor/256x256/apps/olive.png"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_512x512x32.png" \
+ "$pkgdir/usr/share/icons/hicolor/512x512/apps/olive.png"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_1024x1024x32.png" \
+ "$pkgdir/usr/share/icons/hicolor/1024x1024/apps/olive.png"
+}
diff --git a/olive.desktop b/olive.desktop
new file mode 100644
index 000000000000..59eecd9f1caa
--- /dev/null
+++ b/olive.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=Olive
+GenericName=Video Editor
+Comment=Free non-linear video editor
+Exec=Olive
+Icon=olive
+Terminal=false
+StartupNotify=false
+Categories=Qt;AudioVideo;AudioVideoEditing;
+Keywords=editing;video;audio;