summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302020-01-26 12:11:07 +0100
committerM0Rf302020-01-26 12:11:07 +0100
commitf97848da93b53b18acf4acff34bb57c965610696 (patch)
tree700e667b92465516e41271dfe4f801c64bc260ad
parentc2ef8bac4aec8faf9178207e7dc5d395b29e7a81 (diff)
downloadaur-f97848da93b53b18acf4acff34bb57c965610696.tar.gz
soulseekqt: fix LD_LIBRARY_PATH and makedeps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--soulseekqt.sh2
3 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3d62c32a366..25165a563c2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = soulseekqt
pkgdesc = A desktop client for the Soulseek peer-to-peer file sharing network
pkgver = 20180130
- pkgrel = 8
+ pkgrel = 9
url = http://www.soulseekqt.net/news/
arch = x86_64
license = CUSTOM
- makedepends = gcc
depends = freetype2
options = !strip
source = https://www.slsknet.org/SoulseekQt/Linux/SoulseekQt-2018-1-30-64bit-appimage.tgz
@@ -14,7 +13,7 @@ pkgbase = soulseekqt
source = soulseekqt.desktop
md5sums = 1d98331893bc9b9d45ba34f6523353ab
md5sums = 4ed42be654289fc9cd7f4181c363f745
- md5sums = cdc28ff969333f5ef009dfa73c214efc
+ md5sums = 2c44de8164d81d54e458bb38de3eee18
md5sums = 2544611108889c2c4c7a9084672f4d32
pkgname = soulseekqt
diff --git a/PKGBUILD b/PKGBUILD
index f86d1f90517a..52da2f92e3cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,12 @@
pkgname=soulseekqt
pkgver=20180130
_pkgver=2018-1-30
-pkgrel=8
+pkgrel=9
pkgdesc="A desktop client for the Soulseek peer-to-peer file sharing network"
arch=('x86_64')
url="http://www.soulseekqt.net/news/"
license=('CUSTOM')
depends=('freetype2')
-makedepends=('gcc')
source=("https://www.slsknet.org/SoulseekQt/Linux/SoulseekQt-${_pkgver}-64bit-appimage.tgz"
selinux-mock.c
soulseekqt.sh
@@ -46,5 +45,5 @@ package() {
md5sums=('1d98331893bc9b9d45ba34f6523353ab'
'4ed42be654289fc9cd7f4181c363f745'
- 'cdc28ff969333f5ef009dfa73c214efc'
+ '2c44de8164d81d54e458bb38de3eee18'
'2544611108889c2c4c7a9084672f4d32')
diff --git a/soulseekqt.sh b/soulseekqt.sh
index 82f6e14d28fa..52f1aa43390a 100644
--- a/soulseekqt.sh
+++ b/soulseekqt.sh
@@ -1,4 +1,4 @@
#!/bin/bash
cd /opt/soulseekqt
-LD_LIBRARY_PATH=/opt/soulseekqt/lib \
+LD_LIBRARY_PATH=/opt/soulseekqt/lib:/usr/lib \
./SoulseekQt