summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Barri2019-03-17 19:31:51 +1100
committerDavid Barri2019-03-17 19:31:51 +1100
commitf9d6a8d39646d547239fb4f508ff9170283602f0 (patch)
treed0fc8a48214ab62493438d0ad10538ba48076406
parentf1dbd634856c2391c2123ce1f35f9443ee9d9e8f (diff)
downloadaur-f9d6a8d39646d547239fb4f508ff9170283602f0.tar.gz
Add tlc-dist-*
-rw-r--r--PKGBUILD16
-rwxr-xr-xpcal2
-rwxr-xr-xtla-tools2
-rwxr-xr-xtla2sany2
-rwxr-xr-xtla2tex2
-rwxr-xr-xtlc2
-rwxr-xr-xtlc-dist-fp2
-rwxr-xr-xtlc-dist-server2
-rwxr-xr-xtlc-dist-worker2
-rwxr-xr-xtlc-dist-workerfp2
10 files changed, 26 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87b8af08feb0..3d63c05b9823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,22 @@ source=(
'tla2tex'
'tlc'
'tlc-colour'
+ 'tlc-dist-fp'
+ 'tlc-dist-server'
+ 'tlc-dist-worker'
+ 'tlc-dist-workerfp'
)
noextract=('tla2tools.jar')
sha256sums=('1626add371f8e198ea23f86d16d0c72166978456baaa61f1afec901283b92595'
- '81989cdc3072b9ea3c3120cee7d3f8578fc1dc4933ac2a60cd1982227a9d24cc'
- 'c4c083ebedb2ef69a34bfbc4da4bf9b2a2df7b2d5c5053f71e2a9eeec7147b2f'
- '574eb88e87d6c115b8269e350903ded2cebb9c721353c20b92206cc76934fbc6'
- '400c89b5ebc69ea0bc7440415d057ec6d734fd4b884b514beecf61686bf702ed'
+ '9ad7854b6e5ce959ed8be9b6d0bf526b8197b1688881735713e2a6be99a35d18'
+ 'cfbc8a12b0c9071ecf8908f2b3df29fba791e174002209c0d73d24485453f3b8'
+ '93fa12167a3d695a8b43dce9b3610fdd33f3f3e1ebb97121c3f05f871454e1ba'
+ 'c5b185bc06a0010b762100d530d9a5ecfbd0dc8fb2bb464001ed3017be4a592e'
'7a19ee7fa00dd8502aa274abbf6b3cc39c205e78c738bd04bb5a4ee9ac83bfd2'
+ '555ccfa5e688430cad3d9daf6c3cdf3602808c05b0a99d53f9e371b5e7b3773c'
+ '212e01529d197aa9fa638851d6a03c3d5cf8a7eace6c05e44729ed7d60323f5c'
+ '41010eada1dedb7c78e5af8222a113447bfd95393611aebb18fc392496a36e6b'
+ '4099bd05576956bd345a2177fd8556117bee7ede43d51e87eb497c0e382251cc'
)
package() {
diff --git a/pcal b/pcal
index b9f00cd7eef7..b300549c6fc2 100755
--- a/pcal
+++ b/pcal
@@ -1,2 +1,2 @@
#!/bin/sh
-exec java -classpath /usr/share/java/tla2tools.jar pcal.trans "$@"
+exec tla-tools pcal.trans "$@"
diff --git a/tla-tools b/tla-tools
new file mode 100755
index 000000000000..878a3e92eb1e
--- /dev/null
+++ b/tla-tools
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec java -classpath /usr/share/java/tla2tools.jar "$@"
diff --git a/tla2sany b/tla2sany
index 98dfb66a5267..1df81973d7c8 100755
--- a/tla2sany
+++ b/tla2sany
@@ -1,2 +1,2 @@
#!/bin/sh
-exec java -classpath /usr/share/java/tla2tools.jar tla2sany.SANY "$@"
+exec tla-tools tla2sany.SANY "$@"
diff --git a/tla2tex b/tla2tex
index e0fd4f95e3d3..1ca0ac7f44d5 100755
--- a/tla2tex
+++ b/tla2tex
@@ -1,2 +1,2 @@
#!/bin/sh
-exec java -classpath /usr/share/java/tla2tools.jar tla2tex.TLA "$@"
+exec tla-tools tla2tex.TLA "$@"
diff --git a/tlc b/tlc
index ad6519602b15..f937d6773343 100755
--- a/tlc
+++ b/tlc
@@ -1,2 +1,2 @@
#!/bin/sh
-exec java -classpath /usr/share/java/tla2tools.jar tlc2.TLC "$@"
+exec tla-tools tlc2.TLC "$@"
diff --git a/tlc-dist-fp b/tlc-dist-fp
new file mode 100755
index 000000000000..dccc6ac9c4ee
--- /dev/null
+++ b/tlc-dist-fp
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec tla-tools tlc2.tool.distributed.fp.DistributedFPSet "$@"
diff --git a/tlc-dist-server b/tlc-dist-server
new file mode 100755
index 000000000000..0735edec1958
--- /dev/null
+++ b/tlc-dist-server
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec tla-tools tlc2.tool.distributed.TLCServer "$@"
diff --git a/tlc-dist-worker b/tlc-dist-worker
new file mode 100755
index 000000000000..ed328b08ade6
--- /dev/null
+++ b/tlc-dist-worker
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec tla-tools tlc2.tool.distributed.TLCWorker "$@"
diff --git a/tlc-dist-workerfp b/tlc-dist-workerfp
new file mode 100755
index 000000000000..1461db0650b2
--- /dev/null
+++ b/tlc-dist-workerfp
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec tla-tools tlc2.tool.distributed.fp.TLCWorkerAndFPSet "$@"