summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Edson2024-01-21 21:58:38 -0800
committerJason Edson2024-01-21 22:18:57 -0800
commitfa432bdf28c8550ec51b7d15765a4fad49051981 (patch)
treedfc5feb117d4e9c1b0ab262b989bffcd3a7dac75
parent327f30089dbd5646ff00bcd8f8f510b850f53b0f (diff)
downloadaur-fa432bdf28c8550ec51b7d15765a4fad49051981.tar.gz
Split gtk3/gtk4 libs into seperate packages
Packages: vte-notification-common vte-notification-docs vte3-notification vte4-notification
-rw-r--r--.SRCINFO64
-rw-r--r--PKGBUILD128
2 files changed, 127 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ce0cf3d5913..ac63d976cc9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,47 +1,63 @@
pkgbase = vte3-notification
- pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
+ pkgdesc = Virtual Terminal Emulator widget
pkgver = 0.74.2
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.gnome.org/Apps/Terminal/VTE
- arch = i686
arch = x86_64
license = LGPL
- makedepends = gobject-introspection
- makedepends = vala
+ makedepends = cairo
+ makedepends = fribidi
+ makedepends = gi-docgen
makedepends = git
- makedepends = gtk-doc
+ makedepends = gnutls
+ makedepends = gobject-introspection
makedepends = gperf
+ makedepends = gtk3
+ makedepends = gtk4
makedepends = meson
- makedepends = gi-docgen
- depends = gtk3
- depends = gtk4
- depends = pcre2
- depends = gnutls
- depends = fribidi
- depends = systemd-libs
+ makedepends = pcre2
+ makedepends = systemd
+ makedepends = vala
options = !emptydirs
+ options = !lto
source = git+https://gitlab.gnome.org/GNOME/vte#tag=0.74.2
source = vte291-cntnr-precmd-preexec-scroll.patch-effdc88925f27e048c767ea2ca951ef453d4c4b2::https://src.fedoraproject.org/rpms/vte291/raw/effdc88925f27e048c767ea2ca951ef453d4c4b2/f/vte291-cntnr-precmd-preexec-scroll.patch
sha256sums = SKIP
sha256sums = 4e0dc098681f78241178f8aa33b6a59adf78bb13686540f0664285e080301b5b
+pkgname = vte-notification-common
+ pkgdesc = Common files used by vte and vte3/vte4
+ depends = sh
+ provides = vte-common=0.74.2
+ conflicts = vte-common
+
pkgname = vte3-notification
+ pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
+ depends = cairo
+ depends = fribidi
+ depends = gnutls
depends = gtk3
- depends = gtk4
depends = pcre2
- depends = gnutls
- depends = fribidi
- depends = systemd-libs
+ depends = systemd
depends = vte-notification-common
provides = vte3=0.74.2
- provides = vte4=0.74.2
provides = libvte-2.91.so
conflicts = vte3
+
+pkgname = vte4-notification
+ pkgdesc = Virtual Terminal Emulator widget for use with GTK4 with Fedora patches
+ depends = cairo
+ depends = fribidi
+ depends = gnutls
+ depends = gtk4
+ depends = pcre2
+ depends = systemd
+ depends = vte-notification-common
+ provides = vte4=0.74.2
+ provides = libvte-2.91-gtk4.so
conflicts = vte4
-pkgname = vte-notification-common
- pkgdesc = Common files used by vte and vte3
- arch = any
- depends = sh
- provides = vte-common=0.74.2
- conflicts = vte-common
+pkgname = vte-notification-docs
+ pkgdesc = Virtual Terminal Emulator widget documentation
+ provides = vte-docs=0.74.2
+ conflicts = vte-docs
diff --git a/PKGBUILD b/PKGBUILD
index 87b79ad6174e..164e91c72d4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,36 +6,33 @@
pkgbase=vte3-notification
pkgname=(
- ${pkgbase}
- vte-notification-common
+ 'vte-notification-common'
+ 'vte3-notification'
+ 'vte4-notification'
+ 'vte-notification-docs'
)
pkgver=0.74.2
-pkgrel=2
-pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
+pkgrel=3
+pkgdesc='Virtual Terminal Emulator widget'
url='https://wiki.gnome.org/Apps/Terminal/VTE'
-license=(LGPL)
-arch=(
- 'i686'
- 'x86_64'
-)
-depends=(
- 'gtk3'
- 'gtk4'
- 'pcre2'
- 'gnutls'
- 'fribidi'
- 'systemd-libs'
-)
+arch=('x86_64')
+license=('LGPL')
makedepends=(
- 'gobject-introspection'
- 'vala'
+ 'cairo'
+ 'fribidi'
+ 'gi-docgen'
'git'
- 'gtk-doc'
+ 'gnutls'
+ 'gobject-introspection'
'gperf'
+ 'gtk3'
+ 'gtk4'
'meson'
- 'gi-docgen'
+ 'pcre2'
+ 'systemd'
+ 'vala'
)
-options=('!emptydirs')
+options=('!emptydirs' '!lto')
# Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='https://src.fedoraproject.org/rpms/vte291'
@@ -52,7 +49,7 @@ sha256sums=(
'4e0dc098681f78241178f8aa33b6a59adf78bb13686540f0664285e080301b5b'
)
-prepare () {
+prepare() {
cd vte
# Apply patches
@@ -63,7 +60,6 @@ build() {
local meson_options=(
-D b_lto=false
-D docs=true
- -D gtk4=true
)
arch-meson vte build "${meson_options[@]}"
@@ -80,30 +76,80 @@ _pick() {
done
}
-package_vte3-notification(){
- depends+=(vte-notification-common)
+package_vte-notification-common() {
+ pkgdesc='Common files used by vte and vte3/vte4'
+ depends=('sh')
+ provides=("vte-common=${pkgver}")
+ conflicts=('vte-common')
+
+ meson install -C build --destdir "${pkgdir}"
+
+ cd "${pkgdir}"
+
+ _pick vte3 usr/bin/vte-2.91
+ _pick vte3 usr/include/vte-2.91
+ _pick vte3 usr/lib/libvte-2.91.so*
+ _pick vte3 usr/lib/pkgconfig/vte-2.91.pc
+ _pick vte3 usr/lib/girepository-1.0/Vte-2.91.typelib
+ _pick vte3 usr/share/gir-1.0/Vte-2.91.gir
+ _pick vte3 usr/share/glade
+ _pick vte3 usr/share/vala/vapi/vte-2.91.{deps,vapi}
+
+ _pick vte4 usr/bin/vte-2.91-gtk4
+ _pick vte4 usr/include/vte-2.91-gtk4
+ _pick vte4 usr/lib/libvte-2.91-gtk4.so*
+ _pick vte4 usr/lib/pkgconfig/vte-2.91-gtk4.pc
+ _pick vte4 usr/lib/girepository-1.0/Vte-3.91.typelib
+ _pick vte4 usr/share/gir-1.0/Vte-3.91.gir
+ _pick vte4 usr/share/vala/vapi/vte-2.91-gtk4.{deps,vapi}
+
+ _pick docs usr/share/doc
+}
+
+package_vte3-notification() {
+ pkgdesc+=" for use with GTK3 with Fedora patches"
+ depends=(
+ 'cairo'
+ 'fribidi'
+ 'gnutls'
+ 'gtk3'
+ 'pcre2'
+ 'systemd'
+ 'vte-notification-common'
+ )
provides+=(
"vte3=${pkgver}"
- "vte4=${pkgver}"
'libvte-2.91.so'
)
- conflicts=(
- 'vte3'
- 'vte4'
- )
+ conflicts=('vte3')
- meson install -C build --destdir "${pkgdir}"
+ mv vte3/* "${pkgdir}"
+}
- _pick vte-common "${pkgdir}"/etc/profile.d
- _pick vte-common "${pkgdir}"/usr/lib/{systemd,vte-urlencode-cwd}
+package_vte4-notification() {
+ pkgdesc+=" for use with GTK4 with Fedora patches"
+ depends=(
+ 'cairo'
+ 'fribidi'
+ 'gnutls'
+ 'gtk4'
+ 'pcre2'
+ 'systemd'
+ 'vte-notification-common'
+ )
+ provides+=(
+ "vte4=${pkgver}"
+ 'libvte-2.91-gtk4.so'
+ )
+ conflicts=('vte4')
+
+ mv vte4/* "${pkgdir}"
}
-package_vte-notification-common() {
- pkgdesc='Common files used by vte and vte3'
- depends=('sh')
- arch=('any')
- provides=("vte-common=${pkgver}")
- conflicts=('vte-common')
+package_vte-notification-docs() {
+ pkgdesc+=" documentation"
+ provides+=("vte-docs=${pkgver}")
+ conflicts=('vte-docs')
- mv vte-common/* "${pkgdir}"
+ mv docs/* "${pkgdir}"
}