summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-23 09:05:06 -0700
committerMark Wagie2024-01-23 09:05:06 -0700
commitfacf6441c5c6d655cc2422adc6f75098e50dbcc1 (patch)
tree9057970bacf7f5d1a55b89cf7741ae9e26b1df9a
parent2a28bca77d5580ee7c2306644b1bc554c3683ceb (diff)
downloadaur-facf6441c5c6d655cc2422adc6f75098e50dbcc1.tar.gz
4.5.0
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Unvendorize-polib.py.patch12
-rw-r--r--PKGBUILD15
3 files changed, 11 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2636fcddf5c..a885d1fcf1c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = git-cola
pkgdesc = The highly caffeinated Git GUI
- pkgver = 4.4.1
+ pkgver = 4.5.0
pkgrel = 1
url = https://git-cola.github.io
arch = any
@@ -9,7 +9,6 @@ pkgbase = git-cola
checkdepends = desktop-file-utils
makedepends = python-build
makedepends = python-installer
- makedepends = python-jaraco.packaging
makedepends = python-rst.linker
makedepends = python-setuptools-scm
makedepends = python-sphinx
@@ -25,9 +24,9 @@ pkgbase = git-cola
optdepends = python-pyinotify: file system change monitoring
optdepends = python-send2trash: enables "Send to Trash" functionality.
optdepends = tk: to use the built-in ssh-askpass handler
- source = git-cola-4.4.1.tar.gz::https://github.com/git-cola/git-cola/archive/v4.4.1.tar.gz
+ source = git-cola-4.5.0.tar.gz::https://github.com/git-cola/git-cola/archive/v4.5.0.tar.gz
source = 0001-Unvendorize-polib.py.patch
- sha256sums = 231786deef4a384b904ea4bc0856386448e91161cfed1aadf17494f28a5cbfd0
- sha256sums = 00db8356a4bc6f1d9dade64ab04b6f8bada2df22b246e21551ce925de9f95625
+ sha256sums = f8baaf6e168d605bf087e6ef77137089d9f01ea13f7947bb31cc7ac58e5aa248
+ sha256sums = ffeaafbf1495931d3ab5cee439a82bef340d9cb15d4d555a57e93aed47695fc9
pkgname = git-cola
diff --git a/0001-Unvendorize-polib.py.patch b/0001-Unvendorize-polib.py.patch
index 202d6e2ad9a7..96b84e4d5c7b 100644
--- a/0001-Unvendorize-polib.py.patch
+++ b/0001-Unvendorize-polib.py.patch
@@ -39,18 +39,6 @@ index adaf843c..964998e5 100644
build-backend = "setuptools.build_meta"
[tool.black]
-diff --git a/setup.cfg b/setup.cfg
-index c9da4f56..ac3cdc4d 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -35,6 +35,7 @@ packages =
- include_package_data = true
- install_requires =
- importlib_metadata; python_version<"3.8"
-+ polib >= 1.1.1
- PyQt5 >= 5.6.0; python_version>="3.0"
- qtpy >= 1.1.0
- zip_safe = false
--
2.40.0
diff --git a/PKGBUILD b/PKGBUILD
index 5097f53edcca..365ac984fabc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
-pkgver=4.4.1
+pkgver=4.5.0
pkgrel=1
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
@@ -19,7 +19,6 @@ depends=(
makedepends=(
'python-build'
'python-installer'
- 'python-jaraco.packaging'
'python-rst.linker'
'python-setuptools-scm'
'python-sphinx'
@@ -35,8 +34,8 @@ optdepends=(
)
source=("$pkgname-$pkgver.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz"
'0001-Unvendorize-polib.py.patch')
-sha256sums=('231786deef4a384b904ea4bc0856386448e91161cfed1aadf17494f28a5cbfd0'
- '00db8356a4bc6f1d9dade64ab04b6f8bada2df22b246e21551ce925de9f95625')
+sha256sums=('f8baaf6e168d605bf087e6ef77137089d9f01ea13f7947bb31cc7ac58e5aa248'
+ 'ffeaafbf1495931d3ab5cee439a82bef340d9cb15d4d555a57e93aed47695fc9')
prepare() {
cd "$pkgname-$pkgver"
@@ -50,7 +49,8 @@ build() {
cd "$pkgname-$pkgver"
python -m build --wheel --no-isolation
- make prefix=/usr doc
+# make prefix=/usr doc
+ make prefix=/usr man
}
check() {
@@ -58,8 +58,6 @@ check() {
desktop-file-validate share/applications/*.desktop
appstream-util validate-relax --nonet share/metainfo/*.appdata.xml
- # Not running the unit tests because users don't know how to build in a chroot
-
# Run the unit tests
# GIT_CONFIG_NOSYSTEM=true LC_ALL="C.UTF-8" make test V=2
}
@@ -68,7 +66,8 @@ package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- make prefix=/usr DESTDIR="$pkgdir" install-doc
+# make prefix=/usr DESTDIR="$pkgdir" install-doc
+ make prefix=/usr DESTDIR="$pkgdir" install-man
install -Dm644 "contrib/_${pkgname}" -t "$pkgdir/usr/share/zsh/site-functions/"
install -Dm644 "contrib/$pkgname-completion.bash" \