summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:05:53 +0000
committerAntonio Rojas2021-05-08 09:05:53 +0000
commitfaea7451f5466a8d3eb2420b78b04d3dfaf985e0 (patch)
tree7f13fc5839d7107363f381dbf3690ba3a9accbe9
parent70a99f766784348e97445eaa3c55f5968b7a9e8e (diff)
downloadaur-faea7451f5466a8d3eb2420b78b04d3dfaf985e0.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c89d1e90cc55..4d9762956624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = cmst
- pkgdesc = A QT based GUI front end for the connman connection manager with systemtray icon
- pkgver = 2018.01.06
+ pkgdesc = A QT based GUI front end for the connman connection manager
+ pkgver = 2020.11.01
pkgrel = 1
url = https://github.com/andrew-bibb/cmst
- arch = i686
arch = x86_64
- license = MIT (Expat)
+ license = custom:MIT
depends = qt5-base
depends = connman
depends = libxkbcommon-x11
depends = hicolor-icon-theme
- source = https://github.com/andrew-bibb/cmst/releases/download/cmst-2018.01.06/cmst-2018.01.06.tar.xz
- md5sums = f2f08754c1e189f6a1643786a4139de1
+ source = https://github.com/andrew-bibb/cmst/releases/download/2020.11.01/cmst-2020.11.01.tar.xz
+ sha256sums = b81d56fa363b2e700090bc6901d22d42b6f0a0da9547ab8c6fca7ec93b17c14a
pkgname = cmst
diff --git a/PKGBUILD b/PKGBUILD
index 26d8de17ae13..2aeb66c37575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
-#Maintainer: Andrew Bibb <ajbibb@myfairpoint.net>
+# Maintainer: Alad Wenter <alad@archlinux.org>
+# Contributor: Andrew Bibb <ajbibb@myfairpoint.net>
pkgname=cmst
-pkgver=2018.01.06
+pkgver=2020.11.01
pkgrel=1
-pkgdesc="A QT based GUI front end for the connman connection manager with systemtray icon"
-arch=('i686' 'x86_64')
+pkgdesc="A QT based GUI front end for the connman connection manager"
+arch=('x86_64')
url="https://github.com/andrew-bibb/cmst"
-license=('MIT (Expat)')
+license=('custom:MIT')
depends=('qt5-base' 'connman' 'libxkbcommon-x11' 'hicolor-icon-theme')
-source=(https://github.com/andrew-bibb/cmst/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.xz)
+source=("$url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('b81d56fa363b2e700090bc6901d22d42b6f0a0da9547ab8c6fca7ec93b17c14a')
-md5sums=('f2f08754c1e189f6a1643786a4139de1')
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i '/^conf.path =/c conf.path = /usr/share/dbus-1/system.d' apps/rootapp/rootapp.pro
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
qmake-qt5 DISTRO=arch
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir/" install
}