summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQirui Wang2022-08-16 02:21:58 +0800
committerQirui Wang2022-08-16 02:21:58 +0800
commitfb768910001cde59b8ebbc2de69ec5f9400edc01 (patch)
treef4a0d69055a26f879bafb7c5b05e7a0ffe7d0c42
parent0998460a1108f976747aca85cb3090379e106505 (diff)
downloadaur-fb768910001cde59b8ebbc2de69ec5f9400edc01.tar.gz
Use wxwidgets 3.2
-rw-r--r--.SRCINFO13
-rw-r--r--0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch35
-rw-r--r--0001-Use-target-name-without-directory-in-_OBJ-macro.patch23
-rw-r--r--PKGBUILD15
4 files changed, 72 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6231cc7597a2..6a8766b1fea4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aegisub-git
pkgdesc = A general-purpose subtitle editor with ASS/SSA support
pkgver = 3.2.2.r407.6f546951b
- pkgrel = 1
+ pkgrel = 2
url = http://www.aegisub.org
arch = x86_64
license = GPL
@@ -23,18 +23,17 @@ pkgbase = aegisub-git
depends = libgl
depends = libpulse
depends = uchardet
- depends = wxgtk3
+ depends = wxwidgets
depends = zlib
provides = aegisub
conflicts = aegisub
source = aegisub::git+https://github.com/Aegisub/Aegisub.git
source = git+https://github.com/Aegisub/assdraw.git
- source = 0001-Use-target-name-without-directory-in-_OBJ-macro.patch::https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39.patch
- source = 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch::https://github.com/Aegisub/Aegisub/commit/5f235ff459e6a7ec36639894d1f45a638a9d73f3.patch
+ source = 0001-Use-target-name-without-directory-in-_OBJ-macro.patch
+ source = 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 12b191b104fc8fa8745fd98f4aa9d2425699f2e2e719ef2062bdf6a025a045c0
- sha256sums = 9859311688dd4a6f3e2b330109c96aa3d16f54c76a8d2be31b2e505cb9a5e843
+ sha256sums = ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30
+ sha256sums = c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17
pkgname = aegisub-git
-
diff --git a/0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch b/0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
new file mode 100644
index 000000000000..2db0a77ef4df
--- /dev/null
+++ b/0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
@@ -0,0 +1,35 @@
+From 5f235ff459e6a7ec36639894d1f45a638a9d73f3 Mon Sep 17 00:00:00 2001
+From: wangqr <wangqr@wangqr.tk>
+Date: Sun, 23 Feb 2020 00:42:45 -0500
+Subject: [PATCH] Restrict the usage of undocumented wxBitmap ctor to wxWidgets
+ > 3.1.0
+
+Fix build for wxWidgets 3.0
+---
+ src/libresrc/libresrc.cpp | 12 ++++++++++--
+ 1 file changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/src/libresrc/libresrc.cpp b/src/libresrc/libresrc.cpp
+index 79dc0f16cb..b308c69d58 100644
+--- a/src/libresrc/libresrc.cpp
++++ b/src/libresrc/libresrc.cpp
+@@ -22,9 +22,17 @@
+
+ wxBitmap libresrc_getimage(const unsigned char *buff, size_t size, double scale, int dir) {
+ wxMemoryInputStream mem(buff, size);
++#if wxCHECK_VERSION(3, 1, 0)
++ // Since wxWidgets 3.1.0, there is an undocumented third parameter in the ctor of wxBitmap from wxImage
++ // This "scale" parameter sets the logical scale factor of the created wxBitmap
+ if (dir != wxLayout_RightToLeft)
+- return wxBitmap(wxImage(mem), -1, scale);
+- return wxBitmap(wxImage(mem).Mirror(), -1, scale);
++ return wxBitmap(wxImage(mem), wxBITMAP_SCREEN_DEPTH, scale);
++ return wxBitmap(wxImage(mem).Mirror(), wxBITMAP_SCREEN_DEPTH, scale);
++#else
++ if (dir != wxLayout_RightToLeft)
++ return wxBitmap(wxImage(mem));
++ return wxBitmap(wxImage(mem).Mirror());
++#endif
+ }
+
+ wxIcon libresrc_geticon(const unsigned char *buff, size_t size) {
diff --git a/0001-Use-target-name-without-directory-in-_OBJ-macro.patch b/0001-Use-target-name-without-directory-in-_OBJ-macro.patch
new file mode 100644
index 000000000000..9188de8f8c36
--- /dev/null
+++ b/0001-Use-target-name-without-directory-in-_OBJ-macro.patch
@@ -0,0 +1,23 @@
+From 6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39 Mon Sep 17 00:00:00 2001
+From: wangqr <wangqr@wangqr.tk>
+Date: Mon, 17 Feb 2020 14:42:07 +0800
+Subject: [PATCH] Use target name without directory in $*_OBJ macro
+
+Fix Aegisub/Aegisub#171
+---
+ Makefile.target | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.target b/Makefile.target
+index 516ef3c245..5c4c5d2595 100644
+--- a/Makefile.target
++++ b/Makefile.target
+@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
+ # Libraries contain all object files they depend on (but they may depend on other files)
+ # Not using libtool on OS X because it has an unsilenceable warning about a
+ # compatibility issue with BSD 4.3 (wtf)
+-lib%.a: $$($$*_OBJ)
++lib%.a: $$($$(*F)_OBJ)
+ @$(BIN_MKDIR_P) $(dir $@)
+ $(BIN_AR) cru $@ $(filter %.o,$^)
+ $(BIN_RANLIB) $@
diff --git a/PKGBUILD b/PKGBUILD
index 50733ff0b21d..b38b02f75512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=aegisub-git
pkgver=3.2.2.r407.6f546951b
-pkgrel=1
+pkgrel=2
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=(x86_64)
url=http://www.aegisub.org
@@ -23,7 +23,7 @@ depends=(
libgl
libpulse
uchardet
- wxgtk3
+ wxwidgets
zlib
)
makedepends=(
@@ -39,13 +39,15 @@ conflicts=(aegisub)
source=(
aegisub::git+https://github.com/Aegisub/Aegisub.git
git+https://github.com/Aegisub/assdraw.git
- 0001-Use-target-name-without-directory-in-_OBJ-macro.patch::https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39.patch
- 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch::https://github.com/Aegisub/Aegisub/commit/5f235ff459e6a7ec36639894d1f45a638a9d73f3.patch
+ # https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39.patch
+ 0001-Use-target-name-without-directory-in-_OBJ-macro.patch
+ # https://github.com/Aegisub/Aegisub/commit/5f235ff459e6a7ec36639894d1f45a638a9d73f3.patch
+ 0001-Restrict-the-usage-of-undocumented-wxBitmap-ctor-to-.patch
)
sha256sums=('SKIP'
'SKIP'
- '12b191b104fc8fa8745fd98f4aa9d2425699f2e2e719ef2062bdf6a025a045c0'
- '9859311688dd4a6f3e2b330109c96aa3d16f54c76a8d2be31b2e505cb9a5e843')
+ 'ce90cd9a9c56abcbafeb88d33280d53bee5af98cd9e15f50d6a9e49ae1edda30'
+ 'c4039f693996dd20be4e8a460fffb984fd34fd810b16b9b1ca7fc4f35df2cc17')
pkgver() {
cd aegisub
@@ -82,7 +84,6 @@ build() {
./configure \
--prefix=/usr \
- --with-wx-config=/usr/bin/wx-config-gtk3 \
--without-{portaudio,openal,oss} \
--disable-update-checker
make