summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2023-06-21 09:36:09 +0200
committerMartin Rys2023-06-21 09:36:09 +0200
commitfbe050585e9834ba555e5baa08d5bfb192588ee6 (patch)
tree03486c7abc50805fed82f6197d5a14f958cfb4d0
parentb67d663bbc83cb3eceb1aeeb0ecb1c22ca5f4bfe (diff)
downloadaur-fbe050585e9834ba555e5baa08d5bfb192588ee6.tar.gz
Bump loot to 0.20.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--tbb.patch34
3 files changed, 7 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faad803efc77..646ff3f7425c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
- pkgver = 0.19.1
- pkgrel = 7
+ pkgver = 0.20.0
+ pkgrel = 1
url = https://loot.github.io
arch = x86_64
license = GPL3
@@ -24,13 +24,11 @@ pkgbase = loot
depends = libxss
depends = libxtst
depends = qt5-base
- source = loot-0.19.1.tar.gz::https://github.com/loot/loot/archive/0.19.1.tar.gz
+ source = loot-0.20.0.tar.gz::https://github.com/loot/loot/archive/0.20.0.tar.gz
source = libloot-0.19.4.tar.gz::https://github.com/loot/libloot/archive/0.19.4.tar.gz
source = LOOT.desktop
- source = tbb.patch
- sha256sums = 832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1
+ sha256sums = 25b09d8a4ae94887eb889865c889472618207c4728b12c7d252fc58ded1f9c7f
sha256sums = 819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e
sha256sums = 3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb
- sha256sums = 4c94372e800f764fb21218b7cbbf8421cadc60acd532e8ba66b734395f1bb343
pkgname = loot
diff --git a/PKGBUILD b/PKGBUILD
index a998a29c1df6..76c69bf020c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Co-Maintainer: Martin Rys <https://rys.pw/contact>
pkgname=loot
-pkgver=0.19.1
+pkgver=0.20.0
_pkglibver=0.19.4
-pkgrel=7
+pkgrel=1
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
@@ -14,20 +14,12 @@ makedepends=('git' 'cmake' 'rust' 'cbindgen' 'boost' 'onetbb')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
'LOOT.desktop'
- 'tbb.patch' # https://github.com/loot/loot/issues/1864
)
-sha256sums=('832c0a44f8f33963a90987d880e2527f0ae9a175b29451c47d486dfdf4d41df1'
+sha256sums=('25b09d8a4ae94887eb889865c889472618207c4728b12c7d252fc58ded1f9c7f'
'819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e'
'3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
- '4c94372e800f764fb21218b7cbbf8421cadc60acd532e8ba66b734395f1bb343'
)
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < "${srcdir}/tbb.patch"
-}
-
build() {
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"
diff --git a/tbb.patch b/tbb.patch
deleted file mode 100644
index 541b9f942012..000000000000
--- a/tbb.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/src/gui/state/game/game.h
-+++ b/src/gui/state/game/game.h
-@@ -26,6 +26,18 @@
- #ifndef LOOT_GUI_STATE_GAME_GAME
- #define LOOT_GUI_STATE_GAME_GAME
-
-+#ifndef _WIN32
-+#ifdef emit
-+// The TBB library is used on Linux to provide the implementation of the
-+// standard library parallel execution algorithms, but oneTBB 2021.8.0 defines
-+// an emit() function that clashes with Qt's emit macro, which may be defined
-+// when this header is included. As such, undefine the macro before including
-+// the standard library headers, and redefine it afterwards.
-+#undef emit
-+#define LOOT_SHOULD_REDEFINE_EMIT
-+#endif
-+#endif
-+
- #include <execution>
- #include <filesystem>
- #include <functional>
-@@ -34,6 +46,12 @@
- #include <string>
- #include <variant>
-
-+#ifdef LOOT_SHOULD_REDEFINE_EMIT
-+// Assume emit was Qt's emit macro, which is empty.
-+#define emit
-+#undef LOOT_SHOULD_REDEFINE_EMIT
-+#endif
-+
- #include "gui/state/game/game_settings.h"
- #include "gui/state/logging.h"
- #include "loot/api.h"