summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-05-31 21:46:22 +0300
committerCan Celasun2015-05-31 21:46:22 +0300
commitfd2ac615b906d5ef9639cbb5f035f27cb4f275d2 (patch)
treecd4bf717cf86d0a77a24d5fa1fae7c7ff2fb656a
downloadaur-fd2ac615b906d5ef9639cbb5f035f27cb4f275d2.tar.gz
New structure
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--python2.patch25
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b57c801dd96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thunarx-python
+ pkgdesc = Thunarx Python Bindings
+ pkgver = 0.3.0
+ pkgrel = 2
+ url = http://rabbitvcs.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = thunar>=0.4.0
+ depends = pygtk>=2.6.0
+ depends = pygobject>=2.6.0
+ source = http://archive.xfce.org/src/bindings/thunarx-python/0.3/thunarx-python-0.3.0.tar.bz2
+ source = python2.patch
+ md5sums = 86a28c4c34cae534f2793133b4755794
+ md5sums = 6144a91d626ad14b52723edc471369c2
+
+pkgname = thunarx-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f82ebe30f178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+# Contributor: Dmitry Batenkov <dima dot batenkov at gmail dot com>
+
+pkgname=thunarx-python
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="Thunarx Python Bindings"
+arch=('i686' 'x86_64')
+url="http://rabbitvcs.org/"
+depends=('python2' 'thunar>=0.4.0' 'pygtk>=2.6.0' 'pygobject>=2.6.0')
+license=('GPL')
+
+source=(http://archive.xfce.org/src/bindings/thunarx-python/0.3/${pkgname}-${pkgver}.tar.bz2 python2.patch)
+md5sums=('86a28c4c34cae534f2793133b4755794'
+ '6144a91d626ad14b52723edc471369c2')
+build(){
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch -p1 -i $srcdir/python2.patch
+ PYTHON=python2 ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+}
+
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..831a6e509c72
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,25 @@
+diff -aur package.pristine/configure package.new/configure
+--- package.pristine/configure 2011-03-12 23:12:15.000000000 +0200
++++ package.new/configure 2011-03-12 23:21:31.000000000 +0200
+@@ -13307,9 +13307,9 @@
+ fi
+
+
+-PYTHON_CFLAGS="`python-config --includes`"
+-PYTHON_LIBS="`python-config --libs`"
+-PYTHON_LDFLAGS="`python-config --ldflags`"
++PYTHON_CFLAGS="`python2-config --includes`"
++PYTHON_LIBS="`python2-config --libs`"
++PYTHON_LDFLAGS="`python2-config --ldflags`"
+
+
+
+@@ -13339,7 +13339,7 @@
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk codegen" >&5
+ $as_echo_n "checking for pygtk codegen... " >&6; }
+-PYGTK_CODEGEN="/usr/bin/python `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
++PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_CODEGEN" >&5
+ $as_echo "$PYGTK_CODEGEN" >&6; }