summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-09-02 11:55:16 +0200
committerbartus2020-09-02 11:55:16 +0200
commitfdd479a0bc0376345b3ba4bf7364c79eb0806beb (patch)
tree1a3601dcb573493768189c5e6e9835b8caaf5c7c
parentf2803a73973f40c0ea7b647b1484478dbbf665ee (diff)
downloadaur-fdd479a0bc0376345b3ba4bf7364c79eb0806beb.tar.gz
fix dead eigen:3.3.2 link
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a12456d0e5d7..755c9cbc0a1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mve-git
pkgdesc = Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,
- pkgver = r1278.8c24dc2
+ pkgver = r1297.b9117b3
pkgrel = 1
url = http://www.gcc.tu-darmstadt.de/home/proj/mve/
arch = i686
@@ -17,16 +17,19 @@ pkgbase = mve-git
depends = libgl
depends = qt5-base
depends = intel-tbb
+ depends = eigen
source = mve-git::git+https://github.com/simonfuhrmann/mve.git
source = mve-git-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git
source = git+https://github.com/nmoehrle/mvs-texturing.git
source = git+https://github.com/flanggut/smvs.git
source = gtest.patch
+ source = eigen.patch::https://github.com/nmoehrle/mvs-texturing/pull/153.diff
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 06b18787da3a61874fbe9bffd9b90090abe8339e6e91221c7b009c3fb90c655e
+ sha256sums = ef9700addddd58d5abea5f07d7e56ce073fc7cce0c0a33affd5093dd1d12875f
pkgname = mve-git
diff --git a/PKGBUILD b/PKGBUILD
index 02e9630e29c9..fb457c71a97b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=mve-git
-pkgver=r1278.8c24dc2
+pkgver=r1297.b9117b3
pkgrel=1
pkgdesc="Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,"
arch=('i686' 'x86_64')
url="http://www.gcc.tu-darmstadt.de/home/proj/mve/"
license=('BSD' 'GPL')
groups=()
-depends=('libjpeg' 'libtiff' 'libpng' 'libgl' 'qt5-base' 'intel-tbb')
+depends=('libjpeg' 'libtiff' 'libpng' 'libgl' 'qt5-base' 'intel-tbb' 'eigen')
makedepends=('git' 'go-md2man' 'cmake' 'gtest' )
provides=()
options=()
@@ -16,12 +16,14 @@ source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
"git+https://github.com/nmoehrle/mvs-texturing.git"
"git+https://github.com/flanggut/smvs.git"
'gtest.patch'
+ "eigen.patch::https://github.com/nmoehrle/mvs-texturing/pull/153.diff"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '06b18787da3a61874fbe9bffd9b90090abe8339e6e91221c7b009c3fb90c655e')
+ '06b18787da3a61874fbe9bffd9b90090abe8339e6e91221c7b009c3fb90c655e'
+ 'ef9700addddd58d5abea5f07d7e56ce073fc7cce0c0a33affd5093dd1d12875f')
_binar="apps/sfmrecon/sfmrecon
apps/meshconvert/meshconvert
apps/meshalign/meshalign
@@ -39,6 +41,8 @@ prepare() {
cd ${srcdir}/${pkgname}
git apply -v ${srcdir}/gtest.patch
sed -i '/CXXFLAGS*/s/$/ -msse4.2/' libs/sfm/Makefile
+ cd ${srcdir}/mvs-texturing
+ git apply -v ${srcdir}/eigen.patch
}
pkgver() {