summarylogtreecommitdiffstats
path: root/Alien-HDF4-0.06.patch
diff options
context:
space:
mode:
authorElias Elwyn2024-02-14 12:27:21 +1100
committerElias Elwyn2024-02-14 13:42:20 +1100
commit4a7d3f9234144edbeb38f8fa100c6bb4df0bc5ba (patch)
tree4aa02a6358c8bc613c2bfd672cfa82cd45507aa3 /Alien-HDF4-0.06.patch
downloadaur-perl-alien-hdf4.tar.gz
feat: add PKGBUILD
Diffstat (limited to 'Alien-HDF4-0.06.patch')
-rw-r--r--Alien-HDF4-0.06.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/Alien-HDF4-0.06.patch b/Alien-HDF4-0.06.patch
new file mode 100644
index 000000000000..8d2096e5725b
--- /dev/null
+++ b/Alien-HDF4-0.06.patch
@@ -0,0 +1,32 @@
+diff --unified --recursive --text Alien-HDF4-0.06.orig/Makefile.PL Alien-HDF4-0.06.new/Makefile.PL
+--- Alien-HDF4-0.06.orig/Makefile.PL 2019-04-27 12:18:12.000000000 +1000
++++ Alien-HDF4-0.06.new/Makefile.PL 2024-02-14 13:35:23.635563187 +1100
+@@ -7,7 +7,7 @@
+
+ my ($libpath, $libs) = findlibs();
+ die <<EOF unless defined $libpath;
+-Cannot find hdf library, libdf.a.
++Cannot find hdf library, libdf.$Config{so}.
+ Please add the correct library path to Makefile.PL or install HDF
+ EOF
+
+diff --unified --recursive --text Alien-HDF4-0.06.orig/common.pl Alien-HDF4-0.06.new/common.pl
+--- Alien-HDF4-0.06.orig/common.pl 2023-01-28 07:23:33.000000000 +1100
++++ Alien-HDF4-0.06.new/common.pl 2024-02-14 13:35:43.599172154 +1100
+@@ -38,13 +38,13 @@
+ foreach my $libdir ( @HDF_lib_locations ) {
+ return (
+ $libdir, '-lmfhdfalt -ldfalt',
+- ) if -e "$libdir/libdfalt.a";
++ ) if -e "$libdir/libdfalt.$Config{so}";
+ return (
+ $libdir, '-lmfhdf -ldf',
+- ) if -e "$libdir/libdf.a";
++ ) if -e "$libdir/libdf.$Config{so}";
+ return (
+ $libdir, '-lmfhdf -lhdf -lxdr',
+- ) if -e "$libdir/libhdf.a";
++ ) if -e "$libdir/libhdf.$Config{so}";
+ }
+ return;
+ }