summarylogtreecommitdiffstats
path: root/MPMakeFile.patch
diff options
context:
space:
mode:
authorArpit Nema2020-04-16 03:45:58 -0700
committerArpit Nema2020-04-16 03:45:58 -0700
commitff016f49bd4cff73a8d9f9f677e0b6198914e2e5 (patch)
treec160761b190f6dc969aaf216450cc16b46697947 /MPMakeFile.patch
parent16fc355db4e720c0998c8d89872d75159ea7b92d (diff)
downloadaur-opensees.tar.gz
Updating to release 3.2.0
Diffstat (limited to 'MPMakeFile.patch')
-rwxr-xr-xMPMakeFile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/MPMakeFile.patch b/MPMakeFile.patch
new file mode 100755
index 000000000000..8ccda2eef561
--- /dev/null
+++ b/MPMakeFile.patch
@@ -0,0 +1,25 @@
+diff --git a/SRC/Makefile b/SRC/Makefile
+index 0d08b926..f667853d 100644
+--- a/SRC/Makefile
++++ b/SRC/Makefile
+@@ -1034,11 +1034,15 @@ SUPER_LU_OBJ = $(FE)/system_of_eqn/linearSOE/sparseGEN/SuperLU.o \
+ $(FE)/system_of_eqn/linearSOE/mumps/MumpsSolver.o
+ endif
+
+-# ifeq ($(PROGRAMMING_MODE), PARALLEL_INTERPRETERS)
+-# SUPER_LU_OBJ = $(FE)/system_of_eqn/linearSOE/sparseGEN/SuperLU.o \
+-# $(FE)/system_of_eqn/linearSOE/sparseGEN/DistributedSuperLU.o \
+-# $(FE)/system_of_eqn/linearSOE/sparseGEN/DistributedSparseGenColLinSOE.o
+-# endif
++ifeq ($(PROGRAMMING_MODE), PARALLEL_INTERPRETERS)
++SUPER_LU_OBJ = $(FE)/system_of_eqn/linearSOE/sparseGEN/SuperLU.o \
++ $(FE)/system_of_eqn/linearSOE/sparseGEN/DistributedSuperLU.o \
++ $(FE)/system_of_eqn/linearSOE/sparseGEN/DistributedSparseGenColLinSOE.o \
++ $(FE)/system_of_eqn/linearSOE/mumps/MumpsParallelSOE.o \
++ $(FE)/system_of_eqn/linearSOE/mumps/MumpsParallelSolver.o \
++ $(FE)/system_of_eqn/linearSOE/mumps/MumpsSOE.o \
++ $(FE)/system_of_eqn/linearSOE/mumps/MumpsSolver.o
++endif
+
+ CUDA_CLASSES =
+