summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-25 00:49:44 -0300
committerVinícius dos Santos Oliveira2015-06-25 00:49:44 -0300
commit6678ae4f4487dc0685d2bbaeedc63ed3007e997a (patch)
tree9687f074828c67028cc5e4548cd54167573e8ed0 /Makefile.patch
downloadaur-linuxigd.tar.gz
Genesis commit
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..0983d5a1b15d
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile 2011-12-18 21:28:20.784339431 +0100
++++ b/Makefile 2011-12-18 21:29:07.699390803 +0100
+@@ -33,11 +33,11 @@ clean:
+ rm -f *.o upnpd
+
+ install: upnpd
+- install -d $(DESTDIR)/etc/linuxigd
+- install etc/gatedesc.xml $(DESTDIR)/etc/linuxigd
+- install etc/gateconnSCPD.xml $(DESTDIR)/etc/linuxigd
+- install etc/gateicfgSCPD.xml $(DESTDIR)/etc/linuxigd
+- install etc/dummy.xml $(DESTDIR)/etc/linuxigd
++ install -m700 -d $(DESTDIR)/etc/linuxigd
++ install -m600 etc/gatedesc.xml $(DESTDIR)/etc/linuxigd
++ install -m600 etc/gateconnSCPD.xml $(DESTDIR)/etc/linuxigd
++ install -m600 etc/gateicfgSCPD.xml $(DESTDIR)/etc/linuxigd
++ install -m600 etc/dummy.xml $(DESTDIR)/etc/linuxigd
+ install -d $(DESTDIR)$(PREFIX)
+ install -d $(DESTDIR)$(PREFIX)/sbin
+ install upnpd $(DESTDIR)$(PREFIX)/sbin
+@@ -45,5 +45,5 @@ install: upnpd
+ install -d $(DESTDIR)$(PREFIX)/share/man/man8
+ install upnpd.8 $(DESTDIR)$(PREFIX)/share/man/man8
+ install -d $(DESTDIR)/etc
+- if [ ! -f $(DESTDIR)/etc/upnpd.conf ]; then install etc/upnpd.conf $(DESTDIR)/etc; fi
++ if [ ! -f $(DESTDIR)/etc/upnpd.conf ]; then install -m600 etc/upnpd.conf $(DESTDIR)/etc; fi
+