summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorChristopher Luna2018-01-10 20:48:21 -0600
committerChristopher Luna2018-01-10 20:48:21 -0600
commit3f6a22372a2c153f04fa8d0b27af0085706fe552 (patch)
tree69a1116a0e5d2ff957754a807b25f28ff75cd4a3 /Makefile
downloadaur-dkms-hid-sony-shanwan.tar.gz
First commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ad0191072db6
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,11 @@
+obj-m := hid-sony.o
+
+KRELEASE := $(shell uname -r)
+KDIR := /usr/lib/modules/$(KRELEASE)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+clean:
+ $(MAKE) -C $(KDIR) M=$(PWD) clean