aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorChris Fordham2018-10-11 21:56:09 +1100
committerChris Fordham2018-10-11 21:56:09 +1100
commita7f3179082e594f00468f37276b585ff5e37381a (patch)
treee83f089835e374b6d9345672691fa49a4e6a80f0 /Makefile
parent7db15a5b0f5964797bf0c1575fbde393a91767fd (diff)
downloadaur-a7f3179082e594f00468f37276b585ff5e37381a.tar.gz
Add more convenient make targets.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 25 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 42f7e6f1ae9d..ae7e20d43174 100644
--- a/Makefile
+++ b/Makefile
@@ -1,2 +1,26 @@
+build:
+ makepkg -s
+
+docker-build:
+ docker run -i -t --rm -v "$(shell pwd):/usr/local/build/src" flaccid/arch-makepkg
+
clean:
- rm -Rf docker/ src/ pkg/ *.pkg.tar.*
+ rm -Rf \
+ src \
+ pkg \
+ *.pkg.tar.* \
+ .SRCINFO
+
+clean-all:
+ rm -Rf \
+ containerd \
+ docker \
+ docker-ce \
+ libnetwork \
+ moby \
+ runc \
+ src \
+ tini \
+ pkg \
+ *.pkg.tar.* \
+ .SRCINFO