summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGötz Christ2021-10-03 13:21:36 -0500
committerGötz Christ2021-10-03 13:21:36 -0500
commite6116cbc9c857d3f7bc6fc14e7df71f07ee69029 (patch)
tree12230380109855522ce20736bb8dbd90e8807af6 /Makefile
parent3e6f10fda9c18ec66df470321756925400a2dfc6 (diff)
downloadaur-lohit-fonts.tar.gz
Update Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 21 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 8a02706c1167..8de6b1d0dc69 100644
--- a/Makefile
+++ b/Makefile
@@ -1,28 +1,44 @@
-all: clean build git install
+.PHONY: all
+all: build git install
+.PHONY: clean
clean:
rm -r src pkg || true
+.PHONY: geninteg
geninteg:
sed -i '/.*sums=(/,$$d' PKGBUILD
makepkg --geninteg >> PKGBUILD
+.PHONY: srcinfo
srcinfo:
makepkg --printsrcinfo > .SRCINFO
+.PHONY: makepkg
makepkg:
makepkg -s
+.PHONY: build
build: geninteg srcinfo makepkg
+.PHONY: git
git: git_add git_commit
+.PHONY: git_add
git_add:
- git add PKGBUILD .SRCINFO
+ git add PKGBUILD .SRCINFO Makefile
-git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+.PHONY: git_commit
+git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
- git commit -m "Update to ${VERSION}"
+ [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
+.PHONY: install
install:
- makepkg --install
+ makepkg --repackage --install --force
+
+.PHONY: open
+open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+open:
+ xdg-open $(URL)