summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWang Jiajun2015-07-30 16:24:15 +0000
committerWang Jiajun2015-07-30 16:24:15 +0000
commit95de49d004ebc346edc853c5a505991cdae4e836 (patch)
tree79e2719c173382b14593c969121b89b09a13ee77 /PKGBUILD
downloadaur-115upload.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21e2d17ec475
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Wang Jiajun <amesists AT gmail DOT com>
+# Contributors: philacs
+
+pkgname=115upload
+pkgver=1.1.8
+pkgrel=1
+epoch=1
+pkgdesc='115.com big file upload control'
+url='http://115.com'
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=()
+
+if [ "$CARCH" = "i686" ]; then
+ source=("http://115.com/static/install/2014/${pkgname}_v${pkgver}_x86.tar.gz")
+ md5sums=("7a3282809bb1c6389bbebf1e0d1aa9fe")
+elif [ "$CARCH" = "x86_64" ]; then
+ source=("http://115.com/static/install/2014/${pkgname}_v${pkgver}_x64.tar.gz")
+ md5sums=("dfeb3eee82dcca468f297c31a1190b7a")
+fi
+
+package() {
+ cd ${srcdir}
+ if [ "$CARCH" = "i686" ]; then
+ install -D -m644 ${srcdir}/115upload_plugin.so ${pkgdir}/usr/lib/mozilla/plugins/115upload_plugin.so
+ elif [ "$CARCH" = "x86_64" ]; then
+ install -D -m644 ${srcdir}/115upload_plugin.so ${pkgdir}/usr/lib/mozilla/plugins/115upload_plugin.so
+ fi
+}