summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValHue2015-06-09 12:49:56 +0200
committerValHue2015-06-09 12:49:56 +0200
commitb5183801c541f4040a702dcc43330d44aa873d78 (patch)
tree41a654c68425524103b029f2804f107bc566870b /PKGBUILD
downloadaur-2mandvd.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21a055715830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
+# Contributor: moostik <mooostik_at_gmail.com>
+
+pkgname="2mandvd"
+pkgver="1.8.5"
+pkgrel="2"
+pkgdesc="DVD Authoring Maker In Linux Environnement"
+arch=('i686' 'x86_64')
+url="http://2mandvd.tuxfamily.org/"
+license=('GPL')
+depends=('dvd+rw-tools' 'dvdauthor' 'exif' 'ffmpeg' 'ffmpegthumbnailer' 'glu' 'mencoder' 'mjpegtools' 'mplayer' 'netpbm' 'perl' 'qt4' 'sox' 'transcode' 'ttf-dejavu')
+optdepends=('xine-ui: to preview the result')
+provides=("${pkgname}")
+source=("http://download.tuxfamily.org/${pkgname}/2ManDVD-${pkgver}.tar.gz")
+md5sums=('2e9259f4973bc4fd7ae5199c7fdc9f99')
+
+build() {
+ cd "${srcdir}/2ManDVD"
+
+ qmake-qt4 2ManDVD.pro
+
+ sed -i "41s|#ifdef|//#ifdef|" videowrapper.cpp
+ sed -i '42i #if LIBAVFORMAT_VERSION_MAJOR >= 53' videowrapper.cpp
+
+ make
+}
+
+package() {
+ cd "${srcdir}/2ManDVD"
+
+ sed -i "s|chmod -R 755 /usr/share/2ManDVD|chmod -R 755 \$(INSTALL_ROOT)/usr/share/2ManDVD|" Makefile
+
+ make INSTALL_ROOT=${pkgdir} install
+}