summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorheinrich59912015-10-26 00:11:28 +0000
committerheinrich59912015-10-26 00:11:28 +0000
commit7f4e5f8074e665c0e3486a65f522aced2234ac0b (patch)
tree8bde7cd421356cb29eba74ed917da71ea0b1ef42 /PKGBUILD
parent29a706d9e8de14073cedad5b32489c4dcadcb1a7 (diff)
downloadaur-3dgame-git.tar.gz
2015-10-26
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6965515f4b5..8b79c0fc3357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: heinrich5991 <heinrich5991@gmail.com>
pkgname=3dgame-git
-pkgver=20150818
+pkgver=20151025
pkgrel=1
pkgdesc="A voxel game proof-of-concept"
arch=('x86' 'x86_64')
url="https://github.com/speedy-consoles/3dgamecpp"
license=('none')
depends=('boost-libs'
+ 'enet'
'ftgl'
'glew'
'glu'
'libgl'
'log4cxx'
'sdl2'
- 'sdl2_image')
+ 'sdl2_image'
+ 'yaml-cpp')
+makedepends=('boost'
+ 'gtest')
source=('git://github.com/speedy-consoles/3dgamecpp'
'3dgame')
sha256sums=('SKIP'
@@ -28,7 +32,7 @@ package() {
cd "$srcdir"/3dgamecpp/
install -dm755 "$pkgdir"/usr/{lib,share}/3dgame/ "$pkgdir"/usr/bin/
- cp -r *.txt *.conf fonts/ img/ res/ shaders/ "$pkgdir"/usr/share/3dgame/
+ cp -r -- *.conf *.txt *.yml fonts/ img/ res/ shaders/ sounds/ "$pkgdir"/usr/share/3dgame/
install -m755 bin/release/3dgame "$pkgdir"/usr/lib/3dgame/
install -m755 ../3dgame "$pkgdir"/usr/bin/
}