summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 18:21:55 +0200
committerAntonio Rojas2022-04-01 18:21:55 +0200
commita3a23eeb9f1f79132c1cebaf1c64fd20b4d079cb (patch)
tree2183d8bb669595a111e42350cad02ad0c01263b0 /PKGBUILD
downloadaur-abcde.tar.gz
import from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06a6d046bd18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: schuay <jakob.gruber@gmail.com>
+
+pkgname=abcde
+pkgver=2.9.3
+pkgrel=5
+pkgdesc='Frontend command-line utility that grabs tracks off a CD, encodes them to ogg or mp3 format, and tags them, all in one go'
+arch=('any')
+url='https://abcde.einval.com/'
+license=('GPL')
+depends=('bash' 'cd-discid' 'wget' 'vorbis-tools' 'which')
+optdepends=('cdparanoia: Paranoia ripping support'
+ 'flac: FLAC encoding support'
+ 'glyr: album art support'
+ 'imagemagick: album art support'
+ 'lame: MP3 encoding support'
+ 'opus-tools: Opus encoding support'
+ 'python-eyed3: ID3 tag support'
+ 'vorbisgain: Ogg Vorbis normalization support')
+backup=("etc/${pkgname}.conf")
+source=("https://abcde.einval.com/download/abcde-${pkgver}.tar.gz"{,.sign}
+ hostname.patch)
+validpgpkeys=('CEBB52301D617E910390FE16587979573442684E'
+ '742D444A5AFAF2951EF33E7BF8FB375D9CC820B3') # Steve McIntyre, Andrew Strong
+sha256sums=('046cd0bba78dd4bbdcbcf82fe625865c60df35a005482de13a6699c5a3b83124'
+ 'SKIP'
+ '6b4d8e70dbd34ad269db44fdb9f63eccc448b632cfc98d1b635c3ee6a77362ad')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -e "s:normalize-audio:normalize:g" -i ${pkgname}
+ # https://bugs.archlinux.org/task/58046
+ sed -i 's/^#CDDBMETHOD=musicbrainz/CDDBMETHOD=cddb/' abcde.conf
+ # replace inetutils hostname with coreutils uname -n
+ patch -Np1 -i ../hostname.patch
+}
+
+package() {
+ make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" prefix=/usr sysconfdir=/etc install
+}
+