summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkitterhuff2022-08-08 17:03:19 +0000
committerkitterhuff2022-08-08 17:03:19 +0000
commit32b5701922f6b5cc7b40bfc9952df992d6dd6fbb (patch)
tree1ccdfb35358835980c031fdb23bbb57233ca485d /PKGBUILD
parent2e0d5382eaf5e363f8ad557424e8a2a0b098b820 (diff)
downloadaur-aide-selinux.tar.gz
Updated
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD39
1 files changed, 25 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f3e8334bd27..658d2b1a0b2f 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer: Sorin-Mihai Vârgolici <sorin-mihai@vargolici.com>
-# Contributor: Thomas S Hatch <thatch45@gmail.copm>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# (Sole)Maintainer: John Doe <kitterhuff@gmail.com>
+# Ex-maintainer: Sorin-Mihai Vârgolici <sorin-mihai@vargolici.com>
+# Ex-contributor: Thomas S Hatch <thatch45@gmail.copm>
+# Ex-contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Ex-contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Ex-contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
+ ################################################################################
+##################################################################################
+### IF YOUR BUILD FAILS BECAUSE OF "libselinux" NOT BEING ABLE TO BE RESOLVED, ###
+### INSTALL THE "libselinux" PACKAGE FROM THE AUR. ###
+##################################################################################
+ ################################################################################
+
+
+
+
pkgname=aide-selinux
_srcname=aide
-pkgver=0.16.2
-pkgrel=1
+pkgver=0.17.4
+pkgrel=2
pkgdesc='A file integrity checker and intrusion detection program.'
arch=('i686' 'x86_64')
url="http://aide.github.io/"
license=('GPL')
groups=('selinux')
-depends=('acl' 'audit' 'libelf' 'libselinux' 'mhash')
+depends=('acl' 'audit' 'libelf' 'libselinux' 'mhash' 'e2fsprogs' 'pcre') # libselinux is provided by AUR package "libselinux"
conflicts=('aide')
provides=('aide')
backup=('etc/aide.conf')
-source=(https://github.com/$_srcname/$_srcname/releases/download/v$pkgver/$_srcname-$pkgver.tar.gz{,.asc} \
- aide.conf)
-md5sums=('9835914273bb06f9b3263ce36ef7149b'
- 'SKIP'
- 'd029f9796de01dc8a791f89ac931d7fb')
-
+source=("https://github.com/aide/aide/releases/download/v${pkgver}/aide-${pkgver}.tar.gz"{,.asc} \
+ "aide.conf")
+sha256sums=('c81505246f3ffc2e76036d43a77212ae82895b5881d9b9e25c1361b1a9b7a846' # aide-${pkgver}.tar.gz sha256sum
+ 'SKIP'
+ 'dd8f40a6e0a298dd0f457e6d814bc29c3fd5e5061cc9007386e2c2c3c7887f1a') # aide.conf sha256sum
validpgpkeys=('2BBBD30FAAB29B3253BCFBA6F6947DAB68E7B931') # Hannes von Haugwitz <hannes@vonhaugwitz.com>
build() {