summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-05-13 17:37:35 +0800
committerzxp198210052024-05-13 17:37:35 +0800
commit45bda596e5ad76b93e884a86da5a5399147600be (patch)
treebbd6bbbe4fce249a525ee0b3971d261e4dd22ee0 /PKGBUILD
parent1db3c3786cef1d5b0c2c4c3acb870737bbf3b629 (diff)
downloadaur-aihub-git.tar.gz
update to 1.8.7.r0.ge904f1f
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9636843b9ae..720ffb8d9e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=aihub-git
_pkgname=AIHub
-pkgver=1.8.6.r0.g56b8272
+pkgver=1.8.7.r0.ge904f1f
_electronversion=30
pkgrel=1
pkgdesc="A collection of large model capabilities of the client.一款集合多家大模型能力的客户端"
@@ -24,7 +24,7 @@ source=(
"${pkgname%-git}.sh"
)
sha256sums=('SKIP'
- '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
+ '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
pkgver() {
cd "${srcdir}/${pkgname//-/.}"
git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -33,9 +33,10 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-git}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@cfgdirname@|${pkgname%-git}|g" \
-e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-git}.sh"
- gendesk -q -f -n --categories="Utility" --name="${_pkgname}" --exec="${pkgname%-git} %U"
+ gendesk -q -f -n --pkgname="${pkgname%-git}" --categories="Utility" --name="${_pkgname}" --exec="${pkgname%-git} %U"
cd "${srcdir}/${pkgname//-/.}"
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1