summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvinibali2016-02-18 21:03:20 +0100
committervinibali2016-02-18 21:03:20 +0100
commit07aa3cdec78f9975d30bc5b8700e94be1f9e46a6 (patch)
tree9cf883abffa7305594ffd62cd7b1dc6809e84d8e /PKGBUILD
downloadaur-07aa3cdec78f9975d30bc5b8700e94be1f9e46a6.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a1bb7028691
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: vinibali <vinibali1 at gmail dot com>
+
+pkgname=amdctl-git
+pkgver=unknown
+pkgrel=1
+pkgdesc="Set P-State voltages and clock speeds on recent AMD CPUs on Linux.
+Currently supported families are: 10h, 11h, 12h, 14h, 15h"
+arch=(i686 x86_64)
+url="https://github.com/kevinlekiller/amdctl"
+license=('GPLv3')
+depends=()
+source=(https://github.com/kevinlekiller/amdctl/archive/master.zip)
+md5sums=(454746d007ec0cbff2efc5764ca6e288)
+
+build()
+ {
+ echo "No build requied, precompiled binary is avaliable"
+ }
+
+package() {
+
+ install -Dm755 "${srcdir}"/amdctl-master/amdctl "${pkgdir}"/usr/bin/amdctl
+ mkdir "${pkgdir}"/etc/
+ mkdir "${pkgdir}"/etc/modules-load.d
+ touch "${pkgdir}"/etc/modules-load.d/tpc.conf
+ echo "cpuid" > "${pkgdir}"/etc/modules-load.d/tpc.conf
+ echo "msr" >> "${pkgdir}"/etc/modules-load.d/tpc.conf
+}