summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalazs Vinarz2021-09-09 21:21:04 +0200
committerBalazs Vinarz2021-09-09 21:22:01 +0200
commite2c6d89f46d9cff9c9bc55dcfcc467428b12d1aa (patch)
treea45d360a2567a22e30e492f15b7b0f3d5e4664cf /PKGBUILD
parentb88f9a8ba73e671f842e7350a57c33e8fdb0faac (diff)
downloadaur-e2c6d89f46d9cff9c9bc55dcfcc467428b12d1aa.tar.gz
update to FabioLolixs version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 352d5a452c64..b851714e7bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: vinibali <vinibali1 at gmail dot com>
pkgname=amdctl-git
-pkgver=0.3
+pkgver=0.6.1.r2.g146dcc5
pkgrel=1
pkgdesc="Set P-State voltages and clock speeds on recent AMD CPUs on Linux.
-Currently supported families are: 10h, 11h, 12h, 14h, 15h, 16h"
+ Currently supported families are: 10h, 11h, 12h, 14h, 15h, 16h, 17h, 19h"
arch=(i686 x86_64)
url="https://github.com/kevinlekiller/amdctl"
-license=('GPLv3')
-depends=()
-source=(https://github.com/kevinlekiller/amdctl/archive/v"${pkgver}".zip)
-md5sums=(f152b897230bebf4c31ae9c2aae2e61c)
+license=(GPL3)
+depends=(glibc)
+makedepends=(git)
+source=("git+https://github.com/kevinlekiller/amdctl.git"
+ 'amdctl.conf')
+sha256sums=('SKIP'
+ 'a3e2ebec196914ff59fec2683bd2ce900d767979620411cd724138e1ca42701c')
-build()
- {
- cd "${srcdir}"/amdctl-${pkgver}
- make
- }
+pkgver() {
+ cd "${srcdir}/amdctl"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
-package() {
+build() {
+ cd "${srcdir}/amdctl"
+ make
+}
- install -Dm755 "${srcdir}"/amdctl-${pkgver}/amdctl "${pkgdir}"/usr/bin/amdctl
- mkdir "${pkgdir}"/etc/
- mkdir "${pkgdir}"/etc/modules-load.d
- touch "${pkgdir}"/etc/modules-load.d/amdctl.conf
- echo "cpuid" > "${pkgdir}"/etc/modules-load.d/amdctl.conf
- echo "msr" >> "${pkgdir}"/etc/modules-load.d/amdctl.conf
+package() {
+ cd "${srcdir}/amdctl"
+ install -Dm755 amdctl -t "${pkgdir}/usr/bin/"
+ install -Dm755 ../amdctl.conf -t "${pkgdir}/etc/modules-load.d/"
}