summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Sutton2017-10-30 09:03:10 +0000
committerPeter Sutton2017-10-30 09:03:10 +0000
commit58131304001d0931f2e7ec89d1cc026100a15455 (patch)
tree5da794a59e5fc181f0acdcf92309ca951835f269 /PKGBUILD
downloadaur-amidimap.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8b954ed1c53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Peter Sutton <foxxy@foxdogstudios.com>
+pkgname=amidimap
+pkgver=0.1.1
+pkgrel=1
+epoch=
+pkgdesc='Read in MIDI events, process them, and output them again.'
+arch=('i686' 'x86_64')
+url='http://cowlark.com/amidimap/'
+license=('GPL2')
+groups=()
+depends=('alsa-lib')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://cowlark.com/amidimap/$pkgname-$pkgver.tar.bz2")
+noextract=()
+sha256sums=('2940fa73eeb63ee12863cbd697bd500c07524b27b555188ea960260c1cdc8ce1')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 amidimap "$pkgdir/usr/bin/amidimap"
+}