summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDominic2023-11-24 22:49:46 +0100
committerDominic2023-11-24 22:49:46 +0100
commit61e293b920f6d8cfdcaf98528c4480c48101dfe2 (patch)
treef66d431cff08818ba908c9a0e27556cf691897fe /PKGBUILD
parent2a0ec6d4406df187add0dd7c3fd7eabd2d76a541 (diff)
downloadaur-android-ndk-25.tar.gz
android-ndk-25 r25.c-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e644a182625..d700993b6413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Dominic Meiser <git@msrd0.de>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: frownlee <florez.brownlee@gmail.com>
-pkgname=android-ndk
+pkgname=android-ndk-25
pkgver=r25.c
-pkgrel=4
+pkgrel=1
pkgdesc='Android C/C++ developer kit'
arch=('x86_64')
url='https://developer.android.com/ndk/'
license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
-backup=("etc/profile.d/$pkgname.sh")
+backup=("etc/profile.d/android-ndk.sh")
install="$pkgname.install"
+conflicts=('android-ndk')
+provides=("android-ndk=$pkgver")
replaces=('android-ndk64')
depends=('bash' 'glibc' 'gcc-libs' 'zlib')
-# makedepends are just for making namcap happy. AUR packages are not added to
-# avoid unneeded efforts
makedepends=('bzip2' 'libxcrypt-compat' 'python' 'perl' 'libc++')
optdepends=(
'ncurses5-compat-libs: for curses module in bundled Python'
@@ -26,8 +27,8 @@ optdepends=(
'perl: various helper scripts'
'libc++: for some LLVM components'
)
-source=("$pkgname.sh")
-source_x86_64=("https://dl.google.com/android/repository/$pkgname-${pkgver/./}-linux.zip")
+source=("android-ndk.sh")
+source_x86_64=("https://dl.google.com/android/repository/android-ndk-${pkgver/./}-linux.zip")
# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
sha1sums=('38c46b7b1a1c54a0845d027a8eaf37ed0447d3b2')
sha1sums_x86_64=('53af80a1cce9144025b81c78c8cd556bff42bd0e')
@@ -36,11 +37,11 @@ sha256sums_x86_64=('769ee342ea75f80619d985c2da990c48b3d8eaf45f48783a2d48870d04b4
package() {
install -Ddm755 "$pkgdir/opt"
- mv "$pkgname-${pkgver/./}" "$pkgdir/opt/$pkgname"
+ mv "android-ndk-${pkgver/./}" "$pkgdir/opt/android-ndk"
- install -Dm644 $pkgname.sh -t "$pkgdir/etc/profile.d/"
+ install -Dm644 android-ndk.sh -t "$pkgdir/etc/profile.d/"
# make sdkmanager and gradle recognize NDK
install -Ddm755 "$pkgdir"/opt/android-sdk
- ln -s /opt/$pkgname "$pkgdir"/opt/android-sdk/ndk-bundle
+ ln -s /opt/android-ndk "$pkgdir"/opt/android-sdk/ndk-bundle
}