summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-03-02 19:05:59 +0000
committerxiota2024-03-02 19:05:59 +0000
commitdc742baa8ba06c0d87a93f150f53f2c3186b2e7c (patch)
tree80ecf3ee0c4137b741697d26a8d5beabad732ae8 /PKGBUILD
parent1be46a9690db61fbe1ca7672692c8b77bad9ebfc (diff)
downloadaur-annotator-git.tar.gz
1.2.1.r55
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2aea72b9d26..adc1085c3ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
_pkgname="annotator"
pkgname="$_pkgname-git"
-pkgver=1.2.1.r3.g5fc31ff
+pkgver=1.2.1.r55.g8c3d3cce
pkgrel=1
pkgdesc="Image annotation for Elementary OS"
url='https://github.com/phase1geo/Annotator'
-license=("GPL3")
+license=("GPL-3.0-or-later")
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
depends=(
- 'granite'
+ 'granite7'
'libhandy'
+ 'libportal-gtk4'
)
makedepends=(
+ 'cmake'
'git'
'meson'
'vala'
@@ -28,7 +30,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$_pkgsrc"
- git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' 2>/dev/null \
+ git describe --long --tags --abbrev=8 --exclude='*[a-zA-Z][a-zA-Z]*' \
| sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
@@ -45,4 +47,3 @@ package() {
# symlink
ln -sf "com.github.phase1geo.annotator" "$pkgdir/usr/bin/annotator"
}
-