summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2022-03-09 15:33:36 -0500
committerTed Alff2022-03-09 15:33:36 -0500
commit92b1a062284fc744a29322865ab1f6618e8ac4ad (patch)
treefea6abfb35dee7394b472862d5db36a095b79946 /PKGBUILD
parent88aff7f5f3cd1a73c9c61ac45f3a25884f561f29 (diff)
downloadaur-anoise-community-extension1.tar.gz
Remove unnecessary python makedependends and just install the files ourselves.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 232ad825cacd..e4d469bbf138 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: twa022 <twa022 at gmail dot com>
-# Contributor: Yan Burdonsky <psyrccio@gmail.com>
-pkgname=anoise-community-extension1
-pkgver=0.0.1
-pkgrel=5
-pkgdesc="Ambient Noise Community Library Package 1"
+_pkg=1
+_pkgver=('0' '0.0.1' '0.0.4' '0.0.1' '0.0.1' '0.0.1')
+_pkgrel=(0 6 4 6 3 3)
+_folder=(''
+ 'community'
+ 'community-extension2'
+ 'media3'
+ 'community-extension4'
+ 'community-extension5')
+
+pkgname=anoise-community-extension${_pkg}
+pkgver=${_pkgver[${_pkg}]}
+pkgrel=${_pkgrel[${_pkg}]}
+pkgdesc="Ambient Noise Community Library Package ${_pkg}"
arch=('any')
license=('GPL3')
-url="https://code.launchpad.net/anoise"
-makedepends=('python-distutils-extra')
+url='https://code.launchpad.net/anoise'
source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/~costales/+archive/ubuntu/anoise/+sourcefiles/${pkgname}/${pkgver}/${pkgname}_${pkgver}.tar.gz")
sha256sums=('605aafb84a4669cc6d64dec2d93b3585dc260971bcc5db7d63478f8f8901c7b4')
package() {
- cd "${srcdir}/community"
- python ./setup.py install --prefix=/usr --root="${pkgdir}"
+ install -Dm644 ${_folder[${_pkg}]}/sounds/* -t "${pkgdir}"/usr/share/anoise/sounds/
}