summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2018-12-30 10:15:09 -0500
committerTed Alff2018-12-30 10:15:09 -0500
commit922cb62db9d9c980f38c07c8400fbed6ba75a8ee (patch)
tree3f211cb8ae3e1cdc5027fa026ef75c8192375ac1 /PKGBUILD
parent57f8b94f44c133c451820b8dbe8228ab1c6dfa80 (diff)
downloadaur-anoise-gui.tar.gz
Adopt and general cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f0462ef7178..c4286633cf73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,18 @@
-#Maintainer: Yan Burdonsky <psyrccio@gmail.com>
-#Contributor: Yan Burdonsky <psyrccio@gmail.com>
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: Yan Burdonsky <psyrccio@gmail.com>
pkgname=anoise-gui
pkgver=0.0.4
-pkgrel=3
+pkgrel=4
pkgdesc="GUI for Ambient Noise Player"
arch=('any')
license=('GPL3')
url="https://code.launchpad.net/anoise"
-options=()
-conflicts=()
-depends=('anoise' 'python-distutils-extra' 'python-dbus')
-optdepends=()
-source=("https://launchpad.net/~costales/+archive/ubuntu/anoise/+files/${pkgname}_${pkgver}_all.deb")
-sha256sums=('8781f0e070675bf831300a7605b274ece8a0ebcefc423d37543bf650d04e8d56')
-
-build() {
- cd "${srcdir}"
-}
+depends=('anoise' 'python' 'gtk3')
+makedepends=('python-distutils-extra')
+source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/~costales/+archive/ubuntu/anoise/+sourcefiles/${pkgname}/${pkgver}/${pkgname}_${pkgver}.tar.gz")
+sha256sums=('b97553fe661c55d3563dc8031834b51a36387ca3eb856eb78c046e4d8efc868b')
package() {
- cd "${srcdir}"
-
- ar x "${pkgname}_${pkgver}_all.deb" > /dev/null
- tar -xJf data.tar.xz -C "${pkgdir}"
-
- install -d -m755 "${pkgdir}/usr/"
-
+ cd "${srcdir}/${pkgname}"
+ python ./setup.py install --prefix=/usr --root="${pkgdir}"
}