summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2024-04-02 12:17:54 +0700
committerKonstantin Shalygin2024-04-02 12:17:54 +0700
commitebeb0662361f9854f55c271626512fdf5447d83b (patch)
tree1e915b1f1e4c50b12e0fac94fe59f19573f5af2b /PKGBUILD
parentef883e946aa2ce591b04c873e5f0ea5adcc5039d (diff)
downloadaur-ansible-lint-junit.tar.gz
Bump to 0.17.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae3a3f679418..abb80ca3cb1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,24 @@
pkgbase='ansible-lint-junit'
pkgname="python-${pkgbase}"
-pkgver='0.17.7'
+pkgver='0.17.8'
pkgrel='1'
pkgdesc='ansible-lint to JUnit converter'
arch=('any')
url="https://github.com/wasilak/${pkgbase}"
-makedepends=('python' 'python-setuptools' 'python-lxml')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-lxml')
depends=('ansible-lint' 'python-lxml')
license=('BSD')
source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('c887fc2fbe9406967f60544071d26d81c425f2fab79b97bf72ba77ba456df578')
+sha256sums=('c3bc56934d5329195c5157d0df04c2b27b82f8b0c6ea977516597a0a08690305')
+
+build() {
+ cd "${pkgbase}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python setup.py install -O1 --root="${pkgdir}"
+ cd "${pkgbase}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" "dist/"*".whl"
+ install -Dm0644 "LICENSE.txt" "${pkgdir}/usr/share/doc/${pkgbase}/LICENSE"
}