summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 18:10:18 +0100
committerGiovanni Harting2024-03-23 18:10:18 +0100
commitfa5feaf97437280637e050a95e6138312450cfa6 (patch)
tree3c162b42b9974fd292280a616999f2d70ee54692 /PKGBUILD
parent5a76078932b0289a198ff96f37c71f5811d9c5fe (diff)
downloadaur-antidot.tar.gz
upgpkg: antidot 0.6.3-1
upstream release formatting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a09f35dfa27d..4a6ad0258fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
pkgname=antidot
pkgver=0.6.3
pkgrel=1
-pkgdesc="Cleans up your $HOME from those pesky dotfiles"
+pkgdesc='Cleans up your $HOME from those pesky dotfiles'
arch=(x86_64)
url="https://github.com/doron-cohen/$pkgname"
license=(MIT)
depends=(glibc)
makedepends=(go)
-source=("https://github.com/doron-cohen/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
b2sums=('d39b0f0faaf2359dc2d15244da124dfc482d8a9f82d76802facf23bec1812e100606f24e5c832815aaf9907c0d8982b93b3894d599c58443113b532fb37a672c')
prepare(){
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
mkdir -p build/
}
build() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -28,7 +28,7 @@ build() {
}
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}