summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:46:38 +0300
committerKirottu2024-04-03 15:46:38 +0300
commit7ee11679346876999e553b4c54bf641af37c1232 (patch)
treef6bfec150dff5b75a56d73ade851e0737725267e /PKGBUILD
downloadaur-anyrun-plugin-symbols-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f703c507cc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+_pkgname="anyrun-plugin-symbols"
+pkgname="${_pkgname}-git"
+pkgrel=1
+pkgver=1
+pkgdesc="Symbols plugin for searching unicode symbols."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-symbols"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("${_pkgname}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libsymbols.so"
+}