summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:46:43 +0300
committerKirottu2024-04-03 15:46:43 +0300
commitf7f7c80cbe67ef52247a9301ab0038a63944be54 (patch)
treed852fd88a325b1519bed2e0a09c33cb32ae82042 /PKGBUILD
downloadaur-anyrun-plugin-translate-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..226d0b85a897
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+_pkgname="anyrun-plugin-translate"
+pkgname="${_pkgname}-git"
+pkgrel=1
+pkgver=1
+pkgdesc="Translate plugin for quick text translation."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-translate"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("${_pkgname}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libtranslate.so"
+}