summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxwell Pray2023-01-06 10:29:59 -0800
committerMaxwell Pray2023-01-06 10:29:59 -0800
commit53be288bd5391d7b66aacf408d43b60afa9e0c97 (patch)
treec135d070e21d712b7ff72c28ab7a1985d109664e /PKGBUILD
parentc6c802d93fb726b98cf43830c9df92186b3abb7b (diff)
downloadaur-apgdiff.tar.gz
Update to 2.7.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bf6cce302c2..afbd9066932e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Maxwell Pray <synthead@gmail.com>
pkgname=apgdiff
-pkgver=2.4
-pkgrel=3
+pkgver=2.7.0
+pkgrel=1
pkgdesc="A free PostgreSQL diff tool that is useful for comparison/diffing of database schemas"
url="http://www.apgdiff.com/"
depends=('jre11-openjdk-headless')
@@ -11,15 +11,15 @@ makedepends=('maven')
arch=('any')
source=(
'apgdiff'
- "https://www.apgdiff.com/download/$pkgname-$pkgver-src.zip"
+ "https://github.com/fordfrog/apgdiff/archive/refs/tags/release_$pkgver.tar.gz"
)
sha256sums=(
- '83a43b2759e0dc7ec3c4433ec09aef3aae83bdb3f88321d2578bd35b2ab1119f'
- '8551a3e10c7aae3a04efc5dad655575484b63a3323f07db5e81c50b42d88129c'
+ 'd2a627da0011c69c8698a0e78c7b2bdbd9ed90dbca9050490ba5ec6898cbf1f4'
+ '932a7e9fef69a289f4c7bed31a9c0709ebd2816c834b65bad796bdc49ca38341'
)
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-release_$pkgver"
export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
export MAVEN_OPTS="-Dmaven.repo.local=$srcdir/.m2"
@@ -29,7 +29,7 @@ build() {
package() {
install -Dm 644 \
- "$pkgname-$pkgver/target/apgdiff-$pkgver.jar" \
+ "$pkgname-release_$pkgver/target/apgdiff-$pkgver.jar" \
"$pkgdir/usr/share/apgdiff/apgdiff-$pkgver.jar"
install -Dm 755 apgdiff "$pkgdir/usr/bin/apgdiff"