summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-05-03 09:25:14 -0600
committerMark Wagie2024-05-03 09:25:14 -0600
commitd3bf6764c9b03f17c48f005d384ee4d59679b38a (patch)
tree12991c12dfd5fef3700bd1c336c6c27199f67b64 /PKGBUILD
parent69b70f0fbc571bdad4a6214ecb4c2f08f7d64270 (diff)
downloadaur-apostrophe.tar.gz
Fixes & improvements ...
- Add patch to build with reveal.js - Restore hardcoded Fira fonts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 133f91be7813..fc86ce4b36f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=apostrophe
pkgver=3.0
-pkgrel=1
+pkgrel=2
+_reveal_ver=5.1.0
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
@@ -18,6 +19,8 @@ depends=(
'python-pypandoc'
'python-regex'
'python-setuptools'
+ 'ttf-fira-mono'
+ 'ttf-fira-sans'
'webkitgtk-6.0'
)
makedepends=(
@@ -27,33 +30,21 @@ makedepends=(
optdepends=(
'mathjax: for formula preview'
'texlive-bin: for the pdftex module'
- 'ttf-fira-mono: recommended Mono font'
- 'ttf-fira-sans: recommended Sans font'
)
source=("https://gitlab.gnome.org/World/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
- '0001-Use-system-font.patch'
- '2-rm-reveal-check.patch')
+ "https://github.com/hakimel/reveal.js/archive/${_reveal_ver}/reveal.js-${_reveal_ver}.tar.gz"
+ 'embed-reveal.patch')
sha256sums=('5f06a923ab2bffa16ba623f05b7ac67ea75b49891cee99048c157a15dae29f19'
- 'e909c05f259a874afd5e414fd13b0f162972e59c61c23e6d619e502254fcd4fe'
- 'a3e2eea5fca084f53fd6d0f9e61ace8e14b4c83d9c2f1d5ea74c8589c8c10b8f')
+ 'ddc83539ec50583eac9a972e88f892971b37c44e70dd0c08be069e2688684b71'
+ 'd9f140a58a2f65395450a4907263b8c925d6186f90c59e37cc378141be695f5c')
prepare() {
cd "$pkgname-v$pkgver"
+ mkdir -p "$pkgname/libs/reveal.js"
+ cp -r "$srcdir/reveal.js-${_reveal_ver}"/* "$pkgname/libs/reveal.js"
- # Bug 1953395 - Apostrophe can't export to HTML
- sed -i 's|/app/share/fonts/FiraSans-Regular.ttf|/usr/share/fonts/OTF/FiraSans-Regular.otf|' \
- data/media/css/web/base.css
- sed -i 's|/app/share/fonts/FiraMono-Regular.ttf|/usr/share/fonts/OTF/FiraMono-Regular.otf|' \
- data/media/css/web/base.css
-
- # W: hidden-file-or-dir
- rm apostrophe/.pylintrc
-
- # Use system monospace & sans font instead of hard dependency on Fira Mono / Fira Sans
- patch -Np1 -i "$srcdir/0001-Use-system-font.patch"
-
- ## TODO Find a way to package reveal.js
- patch meson.build < "$srcdir/2-rm-reveal-check.patch"
+ # Point Meson to the reveal.js files
+ patch meson.build < "$srcdir/embed-reveal.patch"
}
build() {
@@ -67,4 +58,7 @@ check() {
package() {
meson install -C build --destdir "$pkgdir"
+
+ install -d "$pkgdir/usr/share/$pkgname/libs/reveal.js"
+ cp -r "reveal.js-${_reveal_ver}"/* "$pkgdir/usr/share/$pkgname/libs/reveal.js"
}