summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2019-08-05 21:32:15 +0200
committerMartchus2019-08-05 21:32:15 +0200
commit55bb12e6243dadc4ef6864bf6c8bf5b6af88c118 (patch)
treebc54dd578df842af6249952767a8eef31a7ae101 /PKGBUILD
parent654e51b74c1c2e7b643df1cd968e1cf0e4b28966 (diff)
downloadaur-apple-darwin-osxcross.tar.gz
Update to 325-16efae8 using MacOSX-SDK 10.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD104
1 files changed, 34 insertions, 70 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3af12fd97f38..edb6ab578f5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,43 @@
# Contributor: emersion <contact@emersion.fr>
# This package contains a cross toolchain to compile for MacOSX. It bundles:
-# * MacOSX 10.11 SDK
+# * MacOSX 10.13 SDK
# * wrapper for Clang provided by osxcross
# * wrapper and toolchain file for using Clang with CMake
-# * GCC toolchain (including libstdc++) which is built using the script provided by osxcross
-# Note that GCC is only available for i386, x86_64 but not for x86_64h
# * symlinks for ccache, so it will be used when cross compiling if it is enabled in /etc/makepkg.conf
# Difference between this package and osxcross-git maintained by emersion in the AUR:
# * osxcross-git does not stick to a particular commit
-# * osxcross-git does not provide GCC toolchain (only Clang wrapper)
-# * osxcross-git does not provide CMake toolchain file
+# * osxcross-git does not provide CMake wrapper scripts
# * osxcross-git violates "package etiquette" by putting stuff under /usr/local/osxcross (this package
# uses /opt/osxcross)
# * osxcross-git will likely not work for building other apple-darwin-* packages provided
-# by me, such as apple-darwin-qt5-base (so if you want to build these, use my this package)
+# by me, such as apple-darwin-qt5-base (so if you want to build these, use this package)
# * osxcross-git does not provide symlinks for ccache
# Note that this package includes a MacOSX SDK and hence is not redistributable. Hence it might be worth
# splitting it into:
-# * apple-darwin-sdk-macosx10.11: contains the MacOSX SDK, the only part users would still need to build
-# from sources
+# * apple-darwin-sdk-macosx: contains the particular MacOSX SDK (the only part users would still need
+# to build from sources)
# * apple-darwin-osxcross: contains the actual sources of osxcross reporitory
# * apple-darwin-toolchain: contains the Clang toolchain built with scripts in apple-darwin-osxcross
-# * apple-darwin-gcc: contains the gcc toolchain built with scripts in apple-darwin-osxcross
+# * apple-darwin-gcc: contains the GCC toolchain built with scripts in apple-darwin-osxcross
pkgname=apple-darwin-osxcross
_pkgname=osxcross
-# There's no official release of osxcross yet, so let's just stick to a Git revision
-_osxcrosscommit=a0c5314
-# Use the same GCC and isl version as used by regular gcc package
-_gccver=7.1.1
-_gcccommit=d791474f3fc2133fa0c310e566988b0cbdff321e
-_islver=0.18
-pkgver=272.$_osxcrosscommit
+_osxcrossrevccount=325
+_osxcrosscommit=16efae8
+_sdkname=MacOSX10.13.sdk
+_darwinversion=17
+_prefix=/opt/osxcross # install everything under /opt/osxcross since the toolchain and SKD don't fit well in the regular fs structure
+pkgver=$_osxcrossrevccount.$_osxcrosscommit
pkgrel=1
pkgdesc='OS X cross toolchain for Linux, FreeBSD and NetBSD'
arch=('x86_64')
url='https://github.com/tpoechtrager/osxcross'
license=('MIT')
depends=()
-makedepends=('git' 'libxml2' 'clang>=3.2')
+makedepends=('git' 'libxml2' 'clang>=3.2' 'cmake' 'python' 'libc++')
optdepends=('clang>=3.2: Use Clang (rather than GCC)'
'llvm: Link Time Optimization support and ld64 -bitcode_bundle support'
'uuid: ld64 -random_uuid support'
@@ -50,24 +46,15 @@ optdepends=('clang>=3.2: Use Clang (rather than GCC)'
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/tpoechtrager/${_pkgname}.git#commit=${_osxcrosscommit}"
- 'https://s3.dockerproject.org/darwin/v2/MacOSX10.11.sdk.tar.xz'
+ "https://github.com/phracker/MacOSX-SDKs/releases/download/10.13/$_sdkname.tar.xz"
'apple-darwin-cmake.sh'
- 'toolchain-apple-darwin.cmake'
- '0001-Use-GCC-from-Git-checkout.patch'
- "git+https://gcc.gnu.org/git/gcc.git#commit=${_gcccommit}"
- "http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
- 'Revert-eeb6872bf.patch')
+ 'toolchain-apple-darwin.cmake')
sha256sums=('SKIP'
- '694a66095a3514328e970b14978dc78c0f4d170e590fa7b2c3d3674b75f0b713'
- 'fc3c25980c6d8e32721217b43b7ae272d309a67c94a5ddd105c668d0ea7eb91e'
- 'fa4a430ef0ce168cfbeef4660a67ad08c3e1508ae89ab78b1ea14bb2f6709cb2'
- '34ddb0fb6c08bc19ded7f608264696d7972601b635ee7ece548005286b4ba884'
- 'SKIP'
- '6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- 'c537bce5e9aa2b6fcdec3c1e7f94017633cb5ff5af59beda699262be3c06cca5')
-noextract=('MacOSX10.11.sdk.tar.xz')
+ 'b28b6489ae9287b4f3575bdd6d5450f33e6ea1d2f706d5579f839a494937e8ab'
+ '23fc0013add1d33857019ea539851af20a70efa3c387fc289625ba1dbd755573'
+ '8de19cc38ac2f7b8c4bec060eb36df167d814353c1139f88ed9a1cfb5bc03bc0')
options=('!strip')
-_architectures='i386-apple-darwin15 x86_64-apple-darwin15 x86_64h-apple-darwin15'
+_architectures="i386-apple-darwin$_darwinversion x86_64-apple-darwin$_darwinversion x86_64h-apple-darwin$_darwinversion"
#pkgver() {
# cd "$srcdir/$_pkgname"
@@ -75,75 +62,52 @@ _architectures='i386-apple-darwin15 x86_64-apple-darwin15 x86_64h-apple-darwin15
#}
prepare() {
- cd "${srcdir}/gcc"
-
- msg2 'Prepare GCC (using same steps as in regular GCC package)'
- # link isl for in-tree build
- ln -s ../isl-${_islver} isl
-
- # Do not run fixincludes
- sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
-
- # Arch Linux installs x86_64 libraries /lib
- [[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
-
- # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
-
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80717
- git apply ../Revert-eeb6872bf.patch
+ msg2 '"Package" SDK'
+ cd "$srcdir"
+ # be evil and just copy over headers from libc++ package
+ cp -r /usr/include/c++/v1 "$_sdkname/usr/include/c++"
+ bsdtar cJf "$srcdir/$_pkgname/tarballs/$_sdkname.tar.xz" "$_sdkname"
msg2 'Prepare osxcross'
cd "$srcdir/$_pkgname"
- git apply ../0001-Use-GCC-from-Git-checkout.patch
sed -i -e 's|-march=native||g' build_clang.sh wrapper/build.sh
- # create symlink to SDK file so osxcross can find it
- pushd tarballs && ln -sf ../../MacOSX10.11.sdk.tar.xz MacOSX10.11.sdk.tar.xz && popd
}
build() {
cd "$srcdir/$_pkgname"
export UNATTENDED=yes
- export OSX_VERSION_MIN=10.5
- export ENABLE_FORTRAN=1
- export GCC_VERSION="$_gccver"
- export GCC_CHECKOUT="${srcdir}/gcc"
+ export OSX_VERSION_MIN=10.13
msg2 'Build osxcross'
./build.sh
- msg2 'Build GCC (using build script provided by osxcross)'
- ./build_gcc.sh
-
msg2 'Build toolchain file and wrapper for CMake'
cd "$srcdir"
for _arch in ${_architectures}; do
- sed "s|@TRIPLE@|${_arch}|g" toolchain-apple-darwin.cmake > toolchain-${_arch}.cmake
- sed "s|@TRIPLE@|${_arch}|g" apple-darwin-cmake.sh > ${_arch}-cmake
+ sed -e "s|@TRIPLE@|${_arch}|g" -e "s|@PREFIX@|${_prefix}/SDK/${_sdkname}/usr|g" -e "s|@OSXCROSSDIR@|${_prefix}|g" toolchain-apple-darwin.cmake > toolchain-${_arch}.cmake
+ sed -e "s|@TRIPLE@|${_arch}|g" -e "s|@PREFIX@|${_prefix}/SDK/${_sdkname}/usr|g" -e "s|@OSXCROSSDIR@|${_prefix}|g" apple-darwin-cmake.sh > ${_arch}-cmake
done
- # TODO: Also create a wrapper and a toolchain file for GCC
}
package() {
cd "$srcdir/$_pkgname"
- # install everything under /opt/osxcross since the toolchain and SKD don't fit well in the regular fs structure
- mkdir -p $pkgdir/opt
- cp -r target $pkgdir/opt/osxcross
- install -d "${pkgdir}"/opt/osxcross/share/apple-darwin
+ mkdir -p "$pkgdir/${_prefix%/*}"
+ cp -r target "$pkgdir/${_prefix}"
+ install -d "${pkgdir}/${_prefix}/share/apple-darwin"
# install files for CMake and ccache
cd "$srcdir"
for _arch in ${_architectures}; do
# install toolchain file and wrapper for CMake
- install -t "${pkgdir}"/opt/osxcross/share/apple-darwin -m 644 toolchain-${_arch}.cmake
- install -t "${pkgdir}"/opt/osxcross/bin -m 755 ${_arch}-cmake
+ install -t "${pkgdir}/${_prefix}/share/apple-darwin" -m 644 toolchain-${_arch}.cmake
+ install -t "${pkgdir}/${_prefix}/bin" -m 755 ${_arch}-cmake
# add symlinks for ccache
- local ccachedir="${pkgdir}/opt/osxcross/lib/ccache/bin"
+ local ccachedir="${pkgdir}/${_prefix}/lib/ccache/bin"
mkdir -p "${ccachedir}"
pushd "${ccachedir}"
- for app in clang clang++ gcc g++; do
+ for app in clang clang++; do
ln -s /usr/bin/ccache ./${_arch}-${app}
done
popd