summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsolsTiCe d'Hiver2024-05-19 12:31:39 +0200
committersolsTiCe d'Hiver2024-05-19 12:32:32 +0200
commit2f42868dce79fdc7626e92ba471638f1475a14ad (patch)
tree85caf3eb8c5cb617b495d4144d88a2c110cef551 /PKGBUILD
parent7cef849f6be4b650190bdfce48e23ba8c1f683a2 (diff)
downloadaur-apt-cacher-ng.tar.gz
Fix compilation
* use a helper script for alarm mirrors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbd3c65df4e3..0b958590fbd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=apt-cacher-ng
pkgver=3.7.4
-pkgrel=9
+pkgrel=10
pkgdesc="A caching proxy specialized for package files"
url="http://www.unix-ag.uni-kl.de/~bloch/acng/"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -19,31 +19,35 @@ depends=('zlib' 'bzip2' 'fuse' 'xz' 'openssl' 'libwrap' 'libevent' 'c-ares')
optdepends=('mailcap: to get correct Content-Type header on doc html served by apt-cacher-ng')
makedepends=('cmake')
source=("http://deb.debian.org/debian/pool/main/a/apt-cacher-ng/apt-cacher-ng_${pkgver}.orig.tar.xz"
- 'https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/core/pacman-mirrorlist/mirrorlist'
+ 'add-alarm-mirrorlist.sh'
'acng.conf.patch'
'apt-cacher-ng.service.patch'
- 'have_strlcpy.patch'
+ 'have-strlcpy.patch'
'apt-cacher-ng.tmpfile'
+ 'include-algorithm.patch'
)
backup=('etc/apt-cacher-ng/acng.conf' 'etc/apt-cacher-ng/security.conf')
install=apt-cacher-ng.install
+
sha256sums=('63140473a669c42f5e2219e38fa9d7c733f9047699dde52c3bd828e372929a5f'
- '5d622ca30f7a47e6e9cd536720912e0ef0a1ee96d4a5f3fe7c119cb495aec76f'
+ 'cf6b3fe3ba76c512765c18f10c6ed886bc31c30f28b7ae93f8d6a13d2e65bf30'
'695c074de35a75730e6b711960993f00f120634276349c8640db2ad883a5ad09'
'c89335ea833fc04ec2ce6598e3fdaf86aa8f2fa0892203eef4c0a5cb24d6c188'
'0d584e8193ab2c63d4d629c4fdca23e09dc369953a60c57cbb4a6138b5136265'
- 'ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459')
+ 'ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459'
+ 'de1356ffb2eee9900132f18bbce4f3f56b176553a4fdf334e48b57630e8d0306')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
- patch -i ${srcdir}/have_strlcpy.patch -p0
+ patch -p0 -i "${srcdir}/have-strlcpy.patch"
+ patch -p0 -i "${srcdir}/include-algorithm.patch"
# === uncomment the next line to update mirrors [w3m package is needed]; it will take some time ===
#make -f scripts/Makefile.release gendbs
- # === uncomment next line to add archlinuxarm mirrors to archlx_mirrors file ===
- #grep '^.*Server' ${srcdir}/mirrorlist|sed -e 's/^.*Server = //' -e 's/$arch\/$repo$//' >> conf/archlx_mirrors
+ # === uncomment next line to add archlinuxarm mirrors to archlx_mirrors file [wget is needed] ===
+ #bash ${srcdir}/add-alarm-mirrorlist.sh
}
build() {