summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Wołoszyn2021-01-10 14:40:55 +0100
committerMichał Wołoszyn2021-01-10 14:40:55 +0100
commitc6dc3212ec74b1c6d5f387404ab27ff0d0e5ac71 (patch)
treea2b1df1bdffe074211a565ed68a5c1750fe61adc /PKGBUILD
downloadaur-arcanist-linters-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c7a1d19e1b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michał Wołoszyn <kontakt@fraunos.pl>
+
+_pkgname=arcanist-linters
+pkgname="${_pkgname}-git"
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+pkgver=r106.4b2b839
+pkgrel=1
+pkgdesc='Various linters for Phabricator (via arcanist) by Pinterest'
+arch=('any')
+url="https://github.com/pinterest/arcanist-linters"
+license=('Apache')
+depends=('php' 'python' 'arcanist-git')
+optdepends=('git: Git VCS support'
+ 'subversion: Subversion VCS support'
+ 'mercurial: Mercurial VCS support')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("git+https://github.com/pinterest/arcanist-linters.git")
+sha256sums=('SKIP')
+
+package() {
+ install -d "$pkgdir/usr/share/php/$_pkgname/"
+ cp -a $_pkgname/* "$pkgdir/usr/share/php/$_pkgname/"
+}