summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike McQueen2021-08-14 13:48:25 -0700
committerMike McQueen2021-08-14 13:48:25 -0700
commit46097f660cc74b4f9750be09281f4869c6d2aeb3 (patch)
tree14fd73f0c82dec40f2fd59ee609491fdf7129635 /PKGBUILD
downloadaur-arch-logo-dark-wallpapers.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a15980be85eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: McQueen <clear3239@yahoo.com>
+_pkgname=arch-logo-dark
+pkgname=arch-logo-dark-wallpapers
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Collection of Arch Logo Dark Wallpapers'
+arch=(any)
+url='https://ffwallpaper.com/arch-linux.html'
+_url="https://github.com/MMcQueenGNU"
+license=('CC-BY-SA')
+source=("$_url/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+
+sha256sums=('10edf5e360457fbc7ecf1d250974f4bbfb8b00c6d7e64e52ace802d010333f17')
+
+package() {
+
+ cd "$srcdir/$pkgname-$pkgver/$_pkgname"
+
+ # Creating needed directories
+ install -dm755 "${pkgdir}/usr/share/backgrounds/$_pkgname/"
+
+ # Wallpapers
+ local wallpaper
+ for wallpaper in *; do
+ install -m755 "$srcdir/$pkgname-$pkgver/$_pkgname/${wallpaper}" "$pkgdir/usr/share/backgrounds/$_pkgname/${wallpaper}"
+ done
+}