summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrobin@reportlab.com2015-06-08 17:20:55 +0100
committerrobin@reportlab.com2015-06-08 17:20:55 +0100
commit496ed18009c59a93dd561e75c63a27894271d82c (patch)
treeb67f06c854f68a8bec6a4d4d83960db139c1c068 /PKGBUILD
downloadaur-arch-runit-services.tar.gz
initial checkin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31343dcdcfb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: replabrobin
+# services for arch-runit
+#
+# copyright see
+# http://creativecommons.org/publicdomain/zero/1.0/
+
+pkgname=arch-runit-services
+pkgver=20150530_1544
+_runit_ver=2.1.2
+pkgrel=1
+pkgdesc='Arch native runit package'
+url='https://bitbucket/replabrobin/arch-unit-services'
+license=('Creative Commons')
+arch=('any')
+source=("$pkgname::hg+https://bitbucket.org/replabrobin/arch-runit-services")
+sha256sums=('SKIP')
+depends=()
+makedepends=('mercurial')
+optdepends=()
+provides=('arch-runit-services')
+conflicts=(
+ runit-scripts
+ runit-services
+ runit-services-git
+ void-runit
+ )
+
+build(){
+ true
+ }
+
+pkgver(){
+ cd "$pkgname"
+ hg log --limit=1 --template='{date|isodate}' | sed -e's/ /_/;s/ .*$//;s/-//g;s/://'
+ }
+
+package() {
+ local d
+ cd "$srcdir/$pkgname"
+ install -dm0755 "$pkgdir/etc"
+ install -dm0755 "$pkgdir/etc/sv"
+ for d in *; do
+ [ -f "$d/run" ] && cp -pr $d $pkgdir/etc/sv/$x
+ done
+ }