summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorny-a2021-08-26 13:56:49 +0900
committerny-a2021-08-26 13:57:42 +0900
commit044d78e633fe213bec19e88c62f91d23827ed2a1 (patch)
tree8d7f82a242233c5fee5d57b44e5128c5a0e06d37 /PKGBUILD
downloadaur-arch-wiki-docs-ja.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cecb8ee41cca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ny-a <nyaarch64@gmail..com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=arch-wiki-docs-ja
+_pkgname=arch-wiki-docs
+pkgdesc="Pages from Arch Wiki jp optimized for offline browsing"
+pkgver=20210826
+_commit=b06d5b6e6ab0c95cd3e6dc8ba02b9b2a85bee34d
+pkgrel=1
+arch=('any')
+url="https://github.com/lahwaacz/arch-wiki-docs"
+license=('FDL')
+options=('!strip')
+makedepends=('git' 'python' 'python-simplemediawiki' 'python-lxml' 'python-cssselect' 'python-requests')
+source=("git://github.com/lahwaacz/arch-wiki-docs.git#commit=${_commit}")
+md5sums=('SKIP')
+
+pkgver() {
+ date "+%Y%m%d"
+}
+
+prepare() {
+ cd "$_pkgname"
+ patch -Np1 < ../../archwiki-jp.patch
+ LANG=en_US.UTF-8 python arch-wiki-docs.py --output-directory "$srcdir/build_wiki" --clean --safe-filenames
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/doc/arch-wiki-jp/html"
+ cp -r "$srcdir"/build_wiki/* "$pkgdir/usr/share/doc/arch-wiki-jp/html/"
+}