summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimp0se2015-07-18 15:22:41 -0400
committerimp0se2015-07-18 15:22:41 -0400
commit783d33bc41a4e72ad20f25467d90e03d61fa02de (patch)
tree7cca74d9e0a8ccec02d8b7ec830ffb588186bc31 /PKGBUILD
downloadaur-archey-plus.tar.gz
Inital import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c670d868d8b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: imp0se <undefinedfunc@gmail.com>
+pkgname=archey-plus
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="Based on Archey 0.2.8, adding support for Manjaro, Cinnamon dm/me, and bug fixes"
+
+arch=('any')
+url="https://github.com/imp0se/archey-plus"
+license=('GPL')
+depends=('python2' 'lsb-release' 'scrot')
+makedepends=('git')
+conflicts=('archey' 'archey2')
+provides=('archey')
+source=("git://github.com/imp0se/archey-plus.git")
+md5sums=('SKIP')
+
+#pkgver() {
+# cd ${pkgname}
+# git describe --always | sed 's|-|.|g'
+#}
+
+package() {
+ #cd ${srcdir}
+ #rm -rf archey
+ #msg "Connecting to GIT server...."
+
+ #if [ -d archey ] ; then
+ # cd archey && git pull origin
+ # msg "The local files are updated."
+ #else
+ # git clone ${source}
+ #fi
+
+ #msg "GIT checkout done or server timeout"
+ #msg "Starting make..."
+
+ #cd ${srcdir}/archey
+
+ cd "$srcdir/$pkgname"
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/archey-plus/COPYING
+ install -D -m755 archey ${pkgdir}/usr/bin/archey || return 1
+} \ No newline at end of file