summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-02-18 21:15:45 +0100
committera8212024-02-18 21:15:45 +0100
commit352c76831af59f7b028b125e69d1c1be6eb09ce3 (patch)
tree4a2ec74489f908216163f80fa3ad2b67e05760a5 /PKGBUILD
parent7d82ff7c9e3223b5c2e8f650df59e916441e89fd (diff)
downloadaur-archfetch.tar.gz
Remove sudo and fix package
* remove sudo * pick last commit (there are no tags) * fix awk warnings * use hostnamectl to get the hostname
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9ee0a7e8feb..760797bb383b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: Antoni Kepinski <a[at]kepinski[dot]me>
+# Contributor: Antoni Kepinski <a[at]kepinski[dot]me>
pkgname=archfetch
pkgver=1.0.8
-pkgrel=6
+pkgrel=7
+_commit=47ee3d8c3d9ad4c8585347a39d021f395cabaecb # pick last commit
pkgdesc="Simple CLI system information tool for Arch Linux."
url="https://github.com/xxczaki/archfetch/"
-arch=('i686' 'x86_64')
+arch=('any')
license=('MIT')
makedepends=('git')
-_gitroot="git://github.com/xxczaki/archfetch.git"
-_gitname="archfetch"
+source=("git+https://github.com/xxczaki/archfetch#commit=$_commit")
+sha256sums=('SKIP')
-package() {
- cd "${PKGMK_SOURCE_DIR}"
-
- if cd "${pkgname}"; then
- git fetch -q
- git reset --hard origin/master
- else
- git clone ${_gitroot} ${_gitname}
- cd "${pkgname}"
- fi
+prepare() {
+ cd $pkgname
+ # use systemd's hostnamectl instead of inetutils
+ sed -i 's/(hostname)/(hostnamectl hostname)/' archfetch
+ # fix awk warning
+ sed -i 's/\\"/"/g' archfetch
+}
- sudo make install
+package() {
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}