summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2022-07-06 18:59:26 +0000
committerPellegrino Prevete2022-07-06 18:59:26 +0000
commit417a13fbc481d974131ab112905120ce6d9bfa12 (patch)
tree21cf66cce9f62f263930548c676b274762e079a5 /PKGBUILD
downloadaur-archlinux-ebaseline.tar.gz
standalone baseline (based on ebaseline)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c4dc0c496d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+# shellcheck disable=SC2034
+_pkg="archiso"
+_distro="archlinux"
+_pkgbase="${_pkg}-profiles"
+_profile=ebaseline
+pkgname="${_distro}-${_profile}"
+pkgver=v0.1+11+g1afb2fc
+pkgrel=1
+pkgdesc='Builds an Archlinux desktop'
+arch=('any')
+license=('GPL3')
+url="https://gitlab.${_distro}.org/tallero/${_pkgbase}"
+depends=('archiso-persistent-git'
+ 'cryptsetup-nested-cryptkey'
+ 'fakepkg'
+ 'mkinitcpio-archiso-encryption-git'
+ 'polkit')
+makedepends=('devtools' 'git')
+checkdepends=('shellcheck')
+source=("git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "archiso-profiles" || exit
+ git describe --tags | sed 's/-/+/g'
+}
+
+package() {
+ # shellcheck disable=SC2154
+ local _dest="${pkgdir}/usr/share/${_distro}"
+ local _profile="${srcdir}/${_pkgbase}/${_profile}"
+ cd "${_profile}" || exit
+
+ mkdir -p work
+ ./build_repo.sh fakepkg
+ install -d -m 0755 -- "${_dest}"
+ pkexec mkarchiso -v \
+ -o "${_dest}" \
+ -w "${_profile}/work" \
+ "${_profile}"
+}