summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFinn Lis2019-09-29 08:42:15 +0200
committerFinn Lis2019-09-29 08:42:15 +0200
commit9f61051393943542255ca8b997eb0369ad93206a (patch)
tree79e056905c0ecc786693c4157a88117973bc7037 /PKGBUILD
downloadaur-arizona.tar.gz
First commit of Arizona to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..988a13e56093
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Finn Lis <finn.lis@outlook.com>
+pkgname=arizona
+pkgver=0.12
+pkgrel=1
+pkgdesc="Fast and lightweight audio streaming client for Icecast internet radios"
+arch=('i686' 'x86_64')
+url="https://github.com/tlpr/arizona"
+license=('GPL')
+depends=('mariadb-clients' 'libshout' 'json-c')
+makedepends=('pkgconf' 'make' 'clang')
+_hash="318412592ed93243670db87acd3ed549afe45b25"
+source=("$pkgname-$pkgver.zip::https://github.com/tlpr/arizona/archive/318412592ed93243670db87acd3ed549afe45b25.zip")
+
+build() {
+ cd "$pkgname-$_hash/src"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/local/bin"
+ mkdir -p "$pkgdir/etc"
+ cd "$srcdir/$pkgname-$_hash/src"
+ make DESTDIR="$pkgdir/usr/local/bin" CONFDIR="$pkgdir/etc" install
+}
+
+md5sums=('0891baaa5892c48b3beeeabeb295051e')
+