summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoey Dumont2016-06-09 13:19:55 -0400
committerJoey Dumont2016-06-09 13:19:55 -0400
commit8d997e05c15f3ad8c060d465182795a255df2585 (patch)
tree2ef46b00e8c98248cc48b796e1e116bbc7e24480 /PKGBUILD
parent205cfd5dedddf18cb1ff455c82a145ddee08908b (diff)
downloadaur-8d997e05c15f3ad8c060d465182795a255df2585.tar.gz
Updated to v7.200.1b using bumping up the pkgrel of 7.200.1, as 7.200.1b is seen as a downgrade for pacman.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7a8ce1e43c4..ddca21325f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=armadillo
pkgver=7.200.1
-pkgrel=1
+_pkgver=7.200.1b
+pkgrel=2
pkgdesc="C++ linear algebra library"
arch=('i686' 'x86_64')
url="http://arma.sourceforge.net/"
@@ -13,22 +14,22 @@ optdepends=('hdf5: HDF5 output'
'cuda: NVBLAS support'
'acml-cblas: ACML support')
makedepends=('cmake')
-source=("http://downloads.sourceforge.net/sourceforge/arma/$pkgname-$pkgver.tar.xz")
+source=("http://downloads.sourceforge.net/sourceforge/arma/$pkgname-$_pkgver.tar.xz")
install=armadillo.install
-sha512sums=('c7b45a94d6c1c2754f8b421f4227c7e91a9ed413bc86b2d536b368dde8d86a17cf76ba9f77240ad1d96751d238c0f77921522d4d38dd4138b84466f2c8bfd38c')
+sha512sums=('55ba66c48bce70bb08e2db3dff1bb3cc6a8ff9a962b348705947616e6f6d3161a2f21fa429c5d28bfa15fed6930ba3564c7aa8237ab98d3f99cd8906e6aa5ff0')
build() {
if [ "$CARCH" == "x86_64" ]; then
ARMA64LIBDIR="-DINSTALL_LIB_DIR:PATH=/usr/lib"
fi
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/$pkgname-$_pkgver"
cmake $ARMA64LIBDIR -DCMAKE_INSTALL_PREFIX:PATH=/usr .
make
}
package() {
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/$pkgname-$_pkgver"
make DESTDIR="${pkgdir}" install
install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}