summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAditya2022-09-15 19:52:34 +0530
committerAditya2022-09-15 19:52:34 +0530
commitbe4553840fe8d39f6a1052d6e2cfff4d30e148bd (patch)
tree53b07b668eee26bd296b08c1dbf3d01201f8be01 /PKGBUILD
downloadaur-aru-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22b7e45ec4d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Aditya Mishra <https://github.com/pegvin/aru/issues>
+pkgname=aru-git
+pkgver=f4f034a
+pkgrel=1 # Update if you changed something but that is so minor change you don't want to change the version
+pkgdesc="a text editor"
+arch=('i686' 'x86_64')
+url="https://github.com/pegvin/aru"
+license=('MIT')
+depends=('json-c' 'tre')
+makedepends=(git make scons pkg-config python)
+optdepends=()
+provides=('aru-git')
+conflicts=('aru-git')
+source=(git+https://github.com/pegvin/aru.git)
+sha512sums=(SKIP)
+
+build() {
+ cd aru
+ git submodule update --init --recursive
+ make gen-assets
+ make release
+}
+
+package() {
+ cd aru
+ install -Dm755 aru "$pkgdir/usr/bin/aru"
+}