summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Gathoye2020-02-16 20:40:29 +0100
committerWilliam Gathoye2020-06-09 09:53:26 +0200
commit2f5bdbcb2a305d13443128cb010c23e2b9e3270f (patch)
tree78e5de5ba8f6da2e80a14d0b1a49e6d411541988 /PKGBUILD
parentab231faf91ffcf151fe95303a44594cdfe4e084f (diff)
downloadaur-2f5bdbcb2a305d13443128cb010c23e2b9e3270f.tar.gz
Add module version to differenciate with default module
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2f6480699b9..450bdb088ddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,6 +41,10 @@ prepare() {
sed -i "${srcdir}/${_filename}/Makefile" \
-e 's/^KDIR.*/KDIR = \/lib\/modules\/$(KERNELRELEASE)\/build/g' \
-e 's/SUBDIRS/M/g'
+
+ # Add module version to differenciate with the kernel module from
+ # upstream/Arch Linux kernel.
+ echo "MODULE_VERSION(\"${pkgver}.${pkgrel}\");" >> "${srcdir}/${_filename}/asix.c"
}
package() {