summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Gathoye2019-01-17 20:57:40 +0100
committerWilliam Gathoye2019-01-17 20:57:40 +0100
commit4c0e0f23a120d602381b96a0d19aa03e17c1c5c9 (patch)
tree1f9c46e83a81f49f2c32f7184f539def030eb61a /PKGBUILD
parent8d634a0bc6f25f53547851106b81016a87164609 (diff)
downloadaur-4c0e0f23a120d602381b96a0d19aa03e17c1c5c9.tar.gz
Build against right kernel version
Fixes an issue appearing when the kernel has just been updated, and the module is being rebuild. Until we haven't rebooted, the module was built against the old kernel version (the one running at that moment).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0d0742ef6da..0e089ca994bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=asix-dkms
pkgver=4.23.0
-pkgrel=2
+pkgrel=3
pkgdesc="A kernel module for ASIX AX88760 AX88772 AX88772A AX88772B AX88772C AX88178 USB 2.0 network adapters"
arch=('i686' 'x86_64')
@@ -35,6 +35,10 @@ prepare() {
# Linux kernel internals changed since Linux 4.20.
patch -p1 < "${srcdir}/0001-linux-4.20.patch"
+
+ # Use a DKMS build against the right kernel release
+ sed -i "${srcdir}/${_filename}/Makefile" \
+ -e 's/^KDIR.*/KDIR = \/lib\/modules\/$(KERNELRELEASE)\/build/g'
}
package() {