summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2021-02-23 13:54:58 +0100
committerMagnus Boman2021-02-23 13:54:58 +0100
commit1ab41997ddee51289898fc91abe5f950a34de394 (patch)
tree6dc82fa134762e65e39fe43259b90300dfaa1af6 /PKGBUILD
parentb1cd286838950fc347b3239087338c4c7b428e6c (diff)
downloadaur-audacious-plugins-libopenmpt-git.tar.gz
upgpkg: audacious-plugins-libopenmpt-git 4.1.r11.g9446cf0b9-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 24 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 12e26c53a932..cf90aac28da7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,11 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: William Rea <sillywilly@gmail.com>
+# Set to 1 to use Meson build system
+_use_meson=0
+
pkgname=audacious-plugins-libopenmpt-git
-pkgver=4.0.beta1.r283.g1fc86da9a
+pkgver=4.1.r11.g9446cf0b9
pkgrel=1
pkgdesc='Plugins for Audacious (with libopenpt) (git version)'
arch=(i686 x86_64)
@@ -17,24 +20,39 @@ conflicts=("${pkgname%-libopenmpt-git}")
depends=(audacious-git alsa-lib curl dbus-glib faad2 ffmpeg flac fluidsynth
jack lame libcdio-paranoia libcue libmms libmodplug
libmtp libpulse libnotify libsamplerate libsidplayfp
- libvorbis lirc mpg123 neon wavpack libbs2b libopenmpt gtk2)
+ libvorbis lirc mpg123 neon wavpack libbs2b libopenmpt qt5-x11extras)
makedepends=(glib2 python git)
source=(git+https://github.com/audacious-media-player/"${pkgname%-libopenmpt-git}".git)
md5sums=('SKIP')
+if [ "$_use_meson" = 1 ]; then
+ makedepends+=('meson')
+fi
+
pkgver() {
git -C "${pkgname%-libopenmpt-git}" describe --long --tags | sed 's/^audacious-plugins-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${pkgname%-libopenmpt-git}"
- autoreconf -I m4
- ./configure --prefix=/usr
- make
+ if [ "$_use_meson" = 1 ]; then
+ arch-meson build
+ meson compile -C build
+ else
+ autoreconf
+ ./configure --prefix=/usr
+ make
+ fi
}
package() {
cd "${pkgname%-libopenmpt-git}"
- make DESTDIR="${pkgdir}" install
+
+ if [ "$_use_meson" = 1 ]; then
+ DESTDIR="$pkgdir" meson install -C build
+ else
+ make DESTDIR="$pkgdir" install
+ fi
+
install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}